summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-16 17:55:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-16 18:21:37 +0100
commit0957071ec688336316305b81ccc4db0d2a9d69c9 (patch)
treeb26eb29c655ba806f706397bb0ae6afbb598bea5 /dev-python/pyghmi
parentdev-python/google-api-python-client: Bump to 2.66.0 (diff)
downloadgentoo-0957071ec688336316305b81ccc4db0d2a9d69c9.tar.gz
gentoo-0957071ec688336316305b81ccc4db0d2a9d69c9.tar.bz2
gentoo-0957071ec688336316305b81ccc4db0d2a9d69c9.zip
dev-python/pyghmi: Bump to 1.5.54
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.54.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 137935adc3bd..12b2c4322279 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
DIST pyghmi-1.5.53.tar.gz 245616 BLAKE2B f0dd3d84426c7d1b0e32ae6d666823f2c760b4b6022beb7224af242ab17540f02e47cb321d681ab0153b6cee67c5a35609d45b4af5f9b55896217da8eb089132 SHA512 0f598bcfbfb233ef6a9e7890b914b745c114c67a1c9a5daa6136f498af78c0f6e29e501d5e94a94d47651c11396d154925769d0d7509cc7058a0949545c7eb76
+DIST pyghmi-1.5.54.tar.gz 248634 BLAKE2B 82142cc00972db5e23c893c323d1012b701edeb9844e522b8c2adeeee5f9d96bfc6835a4461f14ae27b595cf4ccdf7c768a403194833f1c6311515c60c2fa9e9 SHA512 6182745a6560f207443042a6f7e56176aabffa32a98b2d20d808b80d8b61febd979281fc207871ec36b26a40c67e453f50e1fc9b2f1581c7a83a561a6e40a435
diff --git a/dev-python/pyghmi/pyghmi-1.5.54.ebuild b/dev-python/pyghmi/pyghmi-1.5.54.ebuild
new file mode 100644
index 000000000000..c181f2b930f7
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.54.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest