summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-25 07:47:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-25 09:12:35 +0200
commit67fea1cc64ac27c5556589edd83ed3b6188a13e1 (patch)
tree327738ff25602d23a13f937024a5208667c0091a /dev-python/pyghmi
parentdev-python/tekore: Bump to 4.4.0 (diff)
downloadgentoo-67fea1cc64ac27c5556589edd83ed3b6188a13e1.tar.gz
gentoo-67fea1cc64ac27c5556589edd83ed3b6188a13e1.tar.bz2
gentoo-67fea1cc64ac27c5556589edd83ed3b6188a13e1.zip
dev-python/pyghmi: Bump to 1.5.43
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.43.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index a84506627aef..c3dc20308dad 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
DIST pyghmi-1.5.42.tar.gz 241338 BLAKE2B f005697a13517f707bc74132d54ebdcc3752409aa147fdc9e99143f1c6a0507e24725e8bc2bc07980e017e6c6fff9868f84bf02fb598a2b580531aba0b66eafc SHA512 ec191a9862a4e6f28a8dbcb54759ad5c3a81ca3f85ecd4c9bbad634a3392296d5aad49d809a099d2719f2235dee2fac962374a4109dee120a4aba521a589afd5
+DIST pyghmi-1.5.43.tar.gz 241608 BLAKE2B edda01665ca4bf5337f8e92aea0fe099597f4c516a3f750ae9747cf80a0710ffc4324c387f826b440f03d30ef68efe93a99122abf9edd03727e32a5e255858f2 SHA512 53f6c4685b395cb3673be8e78c1845c2b0e021d526eb96b3c53a039c7de03e546c7cc6cc1d15003fd1d70ac9d9d2ddadadb62b6b4ee5a95d30c854582bf2785f
diff --git a/dev-python/pyghmi/pyghmi-1.5.43.ebuild b/dev-python/pyghmi/pyghmi-1.5.43.ebuild
new file mode 100644
index 000000000000..1844c945d4be
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.43.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest