summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-07 09:33:01 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-07 09:33:39 +0200
commit7c6b217aa892a259b091a11e7d33d0cf2ee995f0 (patch)
tree501163f341d038834b06754fae0ab25c191967ac /dev-python/pygraphviz/files
parentdev-python/networkx: Add python3 support for pygraphviz (diff)
downloadgentoo-7c6b217aa892a259b091a11e7d33d0cf2ee995f0.tar.gz
gentoo-7c6b217aa892a259b091a11e7d33d0cf2ee995f0.tar.bz2
gentoo-7c6b217aa892a259b091a11e7d33d0cf2ee995f0.zip
dev-python/pygraphviz: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=554436 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pygraphviz/files')
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch29
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch23
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch b/dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch
new file mode 100644
index 000000000000..aed5c9075b88
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch
@@ -0,0 +1,29 @@
+ setup.py | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index fc0a96f..98b7f58 100644
+--- a/setup.py
++++ b/setup.py
+@@ -36,13 +36,6 @@ release.write_versionfile()
+ sys.path.pop(0)
+
+ packages = ["pygraphviz", "pygraphviz.tests"]
+-docdirbase = 'share/doc/pygraphviz-%s' % release.version
+-data = [
+- (docdirbase, glob("*.txt")),
+- (os.path.join(docdirbase, 'examples'), glob("examples/*.py")),
+- (os.path.join(docdirbase, 'examples'), glob("examples/*.dat")),
+- (os.path.join(docdirbase, 'examples'), glob("examples/*.dat.gz")),
+-]
+ package_data = {'': ['*.txt'], }
+
+ if __name__ == "__main__":
+@@ -75,7 +68,6 @@ if __name__ == "__main__":
+ download_url=release.download_url,
+ classifiers=release.classifiers,
+ packages=packages,
+- data_files=data,
+ ext_modules=extension,
+ cmdclass={
+ 'install': AddExtensionInstallCommand,
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch b/dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch
new file mode 100644
index 000000000000..912667e7f5a7
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch
@@ -0,0 +1,23 @@
+ pygraphviz/graphviz.i | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/pygraphviz/graphviz.i b/pygraphviz/graphviz.i
+index 0d9b43b..5f1f6b0 100644
+--- a/pygraphviz/graphviz.i
++++ b/pygraphviz/graphviz.i
+@@ -1,9 +1,9 @@
+-# Copyright (C) 2004-2006 by
+-# Aric Hagberg <hagberg@lanl.gov>
+-# Dan Schult <dschult@colgate.edu>
+-# Manos Renieris, http://www.cs.brown.edu/~er/
+-# Distributed with BSD license.
+-# All rights reserved, see LICENSE for details.
++// Copyright (C) 2004-2006 by
++// Aric Hagberg <hagberg@lanl.gov>
++// Dan Schult <dschult@colgate.edu>
++// Manos Renieris, http://www.cs.brown.edu/~er/
++// Distributed with BSD license.
++// All rights reserved, see LICENSE for details.
+
+ %module graphviz
+