summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-09 09:19:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-09 09:26:19 +0200
commit164ef1cb856a9f6b2fd8f38ae372375c62dabb6c (patch)
treeee991745b7ea46997752d7003b1f85990884755c /dev-python/pygraphviz/pygraphviz-1.7.ebuild
parentdev-python/tenacity: Bump to 8.0.0 (diff)
downloadgentoo-164ef1cb856a9f6b2fd8f38ae372375c62dabb6c.tar.gz
gentoo-164ef1cb856a9f6b2fd8f38ae372375c62dabb6c.tar.bz2
gentoo-164ef1cb856a9f6b2fd8f38ae372375c62dabb6c.zip
dev-python/pygraphviz: Bump to 1.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygraphviz/pygraphviz-1.7.ebuild')
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.7.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/pygraphviz-1.7.ebuild b/dev-python/pygraphviz/pygraphviz-1.7.ebuild
new file mode 100644
index 000000000000..de88e7c96feb
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="https://pygraphviz.github.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-lang/swig:0
+ test? ( dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ epytest
+ rm -rf .hypothesis .pytest_cache || die
+}
+
+python_install_all() {
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ distutils-r1_python_install_all
+}