summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-20 13:00:57 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-20 14:22:29 +0300
commit9cc66d73aa5ec0559c9939325ec259c8520d8500 (patch)
tree38ff244aebd2ce9a9399f7dd5cf0edaf8d928198 /dev-python/pygraphviz
parentapp-admin/awscli: add 1.25.56 (diff)
downloadgentoo-9cc66d73aa5ec0559c9939325ec259c8520d8500.tar.gz
gentoo-9cc66d73aa5ec0559c9939325ec259c8520d8500.tar.bz2
gentoo-9cc66d73aa5ec0559c9939325ec259c8520d8500.zip
dev-python/pygraphviz: add 1.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/Manifest1
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.10.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
index 3d5e9f04cba8..2b9b4a689f1a 100644
--- a/dev-python/pygraphviz/Manifest
+++ b/dev-python/pygraphviz/Manifest
@@ -1 +1,2 @@
+DIST pygraphviz-1.10.zip 120582 BLAKE2B 965b84ec6951c364084ddde4f0594ad7c14eb7e884062ad4f24042b6298b9caf10b3aa33eecfe8154c87c4bfd8d3651acc586129b019aef8b809130d69c03f82 SHA512 571c35f7a8013d5f128fcfbbd68372c8660560847afa0648737eae6d305a9283b69dce23a1b1aeb808bd4eac9c9cefa72b1d358fbc47b724a0b70997ea3f6d84
DIST pygraphviz-1.9.zip 119946 BLAKE2B a399742ae5e8323eec0b6890858cc9158c2942c4f0adb8c74fbfb9745321ae013b93227540e5c328f5dd22d8fba2cf9217a9079f99a14feb983d7188e07084c9 SHA512 0a963b2cfe526c5444379b037797504380898c300256ab3b4800687f46b6230d8bc0adb5f499004a8009544c6cc804221689921c08a4f4b71b86ae01dc39cb7e
diff --git a/dev-python/pygraphviz/pygraphviz-1.10.ebuild b/dev-python/pygraphviz/pygraphviz-1.10.ebuild
new file mode 100644
index 000000000000..96a80374fe2b
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="https://pygraphviz.github.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x86-linux ~ppc-macos ~x64-macos"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-lang/swig:0
+ test? ( dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/install || die
+ epytest
+}
+
+python_install_all() {
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ distutils-r1_python_install_all
+}