summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 09:44:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 11:06:46 +0100
commit1e9e0ddb732c13669d9d9f7a8f3a3088c10ad326 (patch)
tree74928030af4ed46048ac2dca55bc7671ef5767b7 /dev-python/pyicu
parentdev-python/inflect: Bump to 5.4.0 (diff)
downloadgentoo-1e9e0ddb732c13669d9d9f7a8f3a3088c10ad326.tar.gz
gentoo-1e9e0ddb732c13669d9d9f7a8f3a3088c10ad326.tar.bz2
gentoo-1e9e0ddb732c13669d9d9f7a8f3a3088c10ad326.zip
dev-python/pyicu: Bump to 2.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyicu')
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/pyicu-2.8.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index dce4d2a1abbd..37f21a4ef355 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1 +1,2 @@
+DIST pyicu-v2.8.1.tar.bz2 242774 BLAKE2B eeb3c45124301b7072addcbfc3c97521d21fbdb5bdf2b0fe94f0181c225927a0b3bd6ab6271140fa9928d0220e5cb33c800b367cf4b0cf844ad64a2438aa016b SHA512 dc7fb292322c565da045db9d91e9b4cd58a559d6f78bf3f050bf25fbab942179b463b977340e08bbeb107e3a2be8a2eb0a0a91911e0c0b8b96327ba85fd13c46
DIST pyicu-v2.8.tar.bz2 242791 BLAKE2B 0492b1fbbb97a92fb90620fb720cf82ddb2e404d4ce4d20d4204c271ae0c32c526e5832f5658205893381c074f6b1e2a3274f1935efac094241fe2afbc7b9c07 SHA512 c8ecc11322de79d42aa0f0336cdc47637af203bbf2782107132d3c194cef3725114ba6fc40bbd2bffc26ce168d6d4e39f069904aa268d0d095c506ddca292051
diff --git a/dev-python/pyicu/pyicu-2.8.1.ebuild b/dev-python/pyicu/pyicu-2.8.1.ebuild
new file mode 100644
index 000000000000..fc26d61882f3
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/icu:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-python/six[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest