summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-08 09:41:03 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-08 09:41:03 +0200
commit9b41610327e5622bdcebbb6a75da3d0336621dc3 (patch)
tree95c1d64e96edfd05032db80e5e1f61cfcff84971 /dev-python/pynacl
parentdev-python/dulwich: add 0.20.30 (diff)
downloadgentoo-9b41610327e5622bdcebbb6a75da3d0336621dc3.tar.gz
gentoo-9b41610327e5622bdcebbb6a75da3d0336621dc3.tar.bz2
gentoo-9b41610327e5622bdcebbb6a75da3d0336621dc3.zip
dev-python/pynacl: add 1.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pynacl')
-rw-r--r--dev-python/pynacl/Manifest1
-rw-r--r--dev-python/pynacl/pynacl-1.5.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pynacl/Manifest b/dev-python/pynacl/Manifest
index 443a16ab549a..311a29896ee1 100644
--- a/dev-python/pynacl/Manifest
+++ b/dev-python/pynacl/Manifest
@@ -1 +1,2 @@
DIST pynacl-1.4.0.tar.gz 46396758 BLAKE2B 9575bca05ecaf33e798f2abfee7a1af26bbb10b5dbd4e7ca70af8032866e26b88736c2a2ff52e4496e4862f92042fb125df7cd1f1427b16a2313926162466343 SHA512 2a11a623452cea60199cdff83db6f5922698237267c11f055f2fd7768e0875a819dcc08c477113ad89461797ab36d66e0b9c7700eee335eb6b16af6b378b9e88
+DIST pynacl-1.5.0.gh.tar.gz 20350195 BLAKE2B 56ca4f47867cce6e22fdacb0558b5f901aae318b47bacfe5f4ad02d8923e1c86d0a2dd186ec29c820a786ab844d928479fca2d1472a8345b82be6bcbc67c3328 SHA512 905d3a7ce7f758b31a5d34471d5a0202fd2ba3d904a7ec59a158bcd1ea572fc87e29fc144c733d151cbaa48788c939808bc51d00acc973fe6d190eefdd3bfd59
diff --git a/dev-python/pynacl/pynacl-1.5.0.ebuild b/dev-python/pynacl/pynacl-1.5.0.ebuild
new file mode 100644
index 000000000000..d96988d6b304
--- /dev/null
+++ b/dev-python/pynacl/pynacl-1.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
+HOMEPAGE="https://github.com/pyca/pynacl/ https://pypi.org/project/PyNaCl/"
+SRC_URI="https://github.com/pyca/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.4.1[${PYTHON_USEDEP}]
+ dev-libs/libsodium:0/23
+"
+BDEPEND="${RDEPEND}
+ test? ( >=dev-python/hypothesis-3.27.0[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # For not using the bundled libsodium
+ export SODIUM_INSTALL=system
+ distutils-r1_src_prepare
+}