summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2023-01-25 08:31:57 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-05 11:12:52 +0200
commit662b555ca72aca5e749a63fd9c992c48781bc78f (patch)
treeaf0fab6f8f69577fb8299dd19a9a9c27c9397409 /dev-python/pyroute2/pyroute2-0.7.4.ebuild
parentdev-libs/libmemcached-awesome: drop old (diff)
downloadgentoo-662b555ca72aca5e749a63fd9c992c48781bc78f.tar.gz
gentoo-662b555ca72aca5e749a63fd9c992c48781bc78f.tar.bz2
gentoo-662b555ca72aca5e749a63fd9c992c48781bc78f.zip
dev-python/pyroute2: add 0.7.4
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/29256 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2/pyroute2-0.7.4.ebuild')
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyroute2/pyroute2-0.7.4.ebuild b/dev-python/pyroute2/pyroute2-0.7.4.ebuild
new file mode 100644
index 000000000000..094f6662512b
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="https://github.com/svinota/pyroute2"
+
+SRC_URI="
+ https://github.com/svinota/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+# tests need root access
+RESTRICT="test"