summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2023-03-13 08:17:00 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-31 19:10:23 +0200
commitf23d7fa6893ef5522650f15eb502392d13be4dc4 (patch)
tree00b320c9ddf1bb55500eaf4ebef752c4f84b8fdd /dev-python/pyroute2
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.239 (diff)
downloadgentoo-f23d7fa6893ef5522650f15eb502392d13be4dc4.tar.gz
gentoo-f23d7fa6893ef5522650f15eb502392d13be4dc4.tar.bz2
gentoo-f23d7fa6893ef5522650f15eb502392d13be4dc4.zip
dev-python/pyroute2: add 0.7.6
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/30087 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
index 9c0c7f5f9b46..3d024f66c709 100644
--- a/dev-python/pyroute2/Manifest
+++ b/dev-python/pyroute2/Manifest
@@ -1 +1,2 @@
DIST pyroute2-0.7.4.gh.tar.gz 493191 BLAKE2B 3587b391658e7ebf48637a0f03afa36213530d93954f6118ebf5a19fffebc9c22eb2ab9a5db90903dba3e502d91f3f2f7854575c515f314236bf2fe563295314 SHA512 1223bff64625915b11f5fabfe467a469ee33ad63c2daaaaaceaa9f4bf1acb812a93f2b6ff4c6e4d596cefafb1b309a0fed5b5853b44bff62a06cf806b1a681b6
+DIST pyroute2-0.7.6.tar.gz 416681 BLAKE2B f04fc27bafa1b7083d222df315449a51c56dee29993e9f03b18653f938ef50d66dc831e68d13b3115c392283397f2deae6bdda37791253913dadc77a73a9810d SHA512 3e4cbba59c08e52201557dc2814b98f7a1e6e2a567aa1c28ddfbb7da228c01a72eaa6ab42049f1f53b688f9627b7b77a95ab44b5a909ede24d83870d13dfa293
diff --git a/dev-python/pyroute2/pyroute2-0.7.6.ebuild b/dev-python/pyroute2/pyroute2-0.7.6.ebuild
new file mode 100644
index 000000000000..08784a0ce549
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="
+ https://github.com/svinota/pyroute2
+ https://pypi.org/project/pyroute2/
+"
+
+LICENSE="|| ( GPL-2+ Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# tests need root access
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"