summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-28 20:00:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-28 20:32:54 +0200
commit00350a4248ff99500e97f59887d5f3fa84530503 (patch)
treedf715e33333477527cac7a4a251c4e1ca7b3a932 /dev-python/pyscard
parentdev-python/unidecode: Bump to 1.3.5 (diff)
downloadgentoo-00350a4248ff99500e97f59887d5f3fa84530503.tar.gz
gentoo-00350a4248ff99500e97f59887d5f3fa84530503.tar.bz2
gentoo-00350a4248ff99500e97f59887d5f3fa84530503.zip
dev-python/pyscard: Bump to 2.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyscard')
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.0.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 421c462fc1a8..df04f304425b 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1,2 +1,3 @@
DIST pyscard-2.0.3.tar.gz 150092 BLAKE2B af7d58266044792987e6f9a2bc708ca043e32c4f87c8622b5662449254e7d6b630d5769479f3eaf59dc9a3a9fa294330953dea3383aee6c216f3d7dcfd26266a SHA512 2f5c762fe4a7d8d3292f335fda58f8f2f88729ea6d33a508e5f461692fef8d006ccc9b761a78750b8416dc5c1f7c6b06c069e3f6e7b19d91621226590bfef708
DIST pyscard-2.0.4.tar.gz 150740 BLAKE2B 07849c265bfc764dd227bf041add7d24045f8f6669b596307d8a8644c847ee04a868b7df8e69139dc4d65f10b0406ef0083b833ed9e9dca5f11cb5d662d30801 SHA512 6eaae051f22079a73546c78f749dbeedaeee5f776e3f1718cf5ced3ed276d061e2210e2882f74bcaf75de9048fa8f512606a1b4ea0c0d4ecd0a5d6aeac482bc8
+DIST pyscard-2.0.5.tar.gz 150803 BLAKE2B c7d5ab17c3471b050a321c687e5faf33b5faad5a1afc60462b759280cff31bc55d86decdcb16dda9a4afe47848bc06f303c9697941dc212f01b28db6a8469a5e SHA512 bb2ef725e7dccefa640fe1568d1fee016bc5c639769d1b0d099067108e1369b8f7ccd3e48f985d657c5c7c33730eae891624f2c0ee2deaed491826b8c0eae2a5
diff --git a/dev-python/pyscard/pyscard-2.0.5.ebuild b/dev-python/pyscard/pyscard-2.0.5.ebuild
new file mode 100644
index 000000000000..acbc37af89b9
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}