summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 23:02:43 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 23:04:25 +0100
commit36bc549f02f7635ca2547fe0c50bf29458b5b06c (patch)
tree2308be21400c7697c270ad9b39a3e3baf469752b /dev-python/pyspf
parentdev-python/PyRSS2Gen: Switch to PEP 517 build (diff)
downloadgentoo-36bc549f02f7635ca2547fe0c50bf29458b5b06c.tar.gz
gentoo-36bc549f02f7635ca2547fe0c50bf29458b5b06c.tar.bz2
gentoo-36bc549f02f7635ca2547fe0c50bf29458b5b06c.zip
dev-python/pyspf: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyspf')
-rw-r--r--dev-python/pyspf/pyspf-2.0.14-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyspf/pyspf-2.0.14-r3.ebuild b/dev-python/pyspf/pyspf-2.0.14-r3.ebuild
new file mode 100644
index 000000000000..c21474ff960f
--- /dev/null
+++ b/dev-python/pyspf/pyspf-2.0.14-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ipv6(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sender Policy Framework (SPF)"
+HOMEPAGE="https://pypi.org/project/pyspf/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/authres[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" testspf.py || die "Test fail with ${EPYTHON}"
+}