summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-07-14 15:37:21 -0700
committerPatrice Clement <monsieurp@gentoo.org>2016-08-30 17:29:30 +0200
commitf91bd4a5dac8cb786cb607dd75b8cce8514c2c24 (patch)
treed291dd9911e0eecd8fec0a313b548fca097e3d79 /dev-python/pyswisseph
parentapp-vim/nginx-syntax: add ~x86-fbsd keyword. (diff)
downloadgentoo-f91bd4a5dac8cb786cb607dd75b8cce8514c2c24.tar.gz
gentoo-f91bd4a5dac8cb786cb607dd75b8cce8514c2c24.tar.bz2
gentoo-f91bd4a5dac8cb786cb607dd75b8cce8514c2c24.zip
app-misc/openastro{,-data}, dev-python/pyswisseph: new package.
openastro is an open source astrology program written in Python. Gentoo-Bug: https://bugs.gentoo.org/586110 Closes: https://github.com/gentoo/gentoo/pull/1888 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/pyswisseph')
-rw-r--r--dev-python/pyswisseph/Manifest1
-rw-r--r--dev-python/pyswisseph/metadata.xml20
-rw-r--r--dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild29
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pyswisseph/Manifest b/dev-python/pyswisseph/Manifest
new file mode 100644
index 000000000000..ca7f91695a78
--- /dev/null
+++ b/dev-python/pyswisseph/Manifest
@@ -0,0 +1 @@
+DIST pyswisseph-2.00.00-2.tar.bz2 458443 SHA256 7b47f54a61ac17863a4d9e75269e53e09ad525780ac731eed6923415caa725cc SHA512 009542d370248989489e4d2a557b5f5cac27923bc06b9a9088b282f3f9cc8b31bfc43bba9cff3a44f8a77e20356b8a9ced60ec200b26815780af5588efbc9e4b WHIRLPOOL 0521769bed1311fe2c59d14f0a100873b06207ab59bf33cd8a54471958690b12b19ca57f3a7d99829f356c2193a5df1562b976ae2726c11e1800bd35aaf7b5c4
diff --git a/dev-python/pyswisseph/metadata.xml b/dev-python/pyswisseph/metadata.xml
new file mode 100644
index 000000000000..812a6c8ecf52
--- /dev/null
+++ b/dev-python/pyswisseph/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>lluixhi@gmail.com</email>
+ <name>Aric Belsito</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/astrorigin/pyswisseph/issues</bugs-to>
+ <maintainer status="active">
+ <email>smarquis@astrorigin.ch</email>
+ <name>Stanislas Marquis</name>
+ </maintainer>
+ <remote-id type="github">astrorigin/pyswisseph</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild b/dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild
new file mode 100644
index 000000000000..29623a0b68fa
--- /dev/null
+++ b/dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_PV=${MY_PV}-${PLEVEL}
+
+DESCRIPTION="Python extension to the AstroDienst Swiss Ephemeris"
+HOMEPAGE="https://github.com/astrorigin/pyswisseph"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/astrorigin/pyswisseph.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"