summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-16 20:33:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-16 21:19:36 +0200
commitfb884779d31c23fe43ba768df69a3b83e10fabf1 (patch)
treecebcf3f2a26648c130e642f744f9541502bebaad /dev-python/pytesseract
parentdev-python/aiohappyeyeballs: Bump to 2.3.6 (diff)
downloadgentoo-fb884779d31c23fe43ba768df69a3b83e10fabf1.tar.gz
gentoo-fb884779d31c23fe43ba768df69a3b83e10fabf1.tar.bz2
gentoo-fb884779d31c23fe43ba768df69a3b83e10fabf1.zip
dev-python/pytesseract: Bump to 0.3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytesseract')
-rw-r--r--dev-python/pytesseract/Manifest1
-rw-r--r--dev-python/pytesseract/pytesseract-0.3.13.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytesseract/Manifest b/dev-python/pytesseract/Manifest
index f0828998a666..a02f26658f2d 100644
--- a/dev-python/pytesseract/Manifest
+++ b/dev-python/pytesseract/Manifest
@@ -1 +1,2 @@
DIST pytesseract-0.3.12.gh.tar.gz 1099117 BLAKE2B 07fa50a552347a0f6be536933b98056c78d96e7317a9eb325faa5b4a1a2ef66bd2936ab17ca0abe2e56a0c1da75ca675f2a3c5260fc2882072d6535b78b519dc SHA512 931fcd03a7682cbebc42b1452519ef05ef4c931a47a4364841e0fc5861c9dd9f90ffe38f3211ed3846788dc29eefbc9aba2bbf2af30fb3816abdfcaaa6757365
+DIST pytesseract-0.3.13.gh.tar.gz 1099109 BLAKE2B 72bd060c070471cd85ef467c4ba339c0e88c151d2af768212071a35e79169f718907a2dbedb53f10821ce69302253e01181bfa29b1e9b4af1847dac5453c7aba SHA512 da5edaaca8a0c796c2a47777e4b894824b16522d7d3a0e8f669a183bcbdfdf0d0412de4ca53d5bef082fd2b627356e7fd21f86e3107525a99a011fcaba5adacf
diff --git a/dev-python/pytesseract/pytesseract-0.3.13.ebuild b/dev-python/pytesseract/pytesseract-0.3.13.ebuild
new file mode 100644
index 000000000000..0d3ddecce9b2
--- /dev/null
+++ b/dev-python/pytesseract/pytesseract-0.3.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Optical character recognition (OCR) tool"
+HOMEPAGE="
+ https://github.com/madmaze/pytesseract/
+ https://pypi.org/project/pytesseract/
+"
+SRC_URI="
+ https://github.com/madmaze/pytesseract/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ app-text/tesseract
+"
+BDEPEND="
+ test? (
+ app-text/tesseract[jpeg,png,tiff,webp]
+ media-libs/leptonica[gif,jpeg2k]
+ app-text/tessdata_fast[l10n_fr]
+ dev-python/pillow[jpeg,zlib]
+ )
+"
+
+distutils_enable_tests pytest