summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-28 09:36:44 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-28 10:03:44 +0100
commit02a0928e79f3b3e221342efced743d81017b0f60 (patch)
tree910dbfb4bf04b94a6edc850f0e26f1d01831dddf /dev-python/pytest-codeblocks
parentdev-python/pygame: Bump to 2.1.2 (diff)
downloadgentoo-02a0928e79f3b3e221342efced743d81017b0f60.tar.gz
gentoo-02a0928e79f3b3e221342efced743d81017b0f60.tar.bz2
gentoo-02a0928e79f3b3e221342efced743d81017b0f60.zip
Rename dev-python/{exdown → pytest-codeblocks}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-codeblocks')
-rw-r--r--dev-python/pytest-codeblocks/Manifest1
-rw-r--r--dev-python/pytest-codeblocks/metadata.xml17
-rw-r--r--dev-python/pytest-codeblocks/pytest-codeblocks-0.9.0.ebuild23
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-codeblocks/Manifest b/dev-python/pytest-codeblocks/Manifest
new file mode 100644
index 000000000000..06d6a4509152
--- /dev/null
+++ b/dev-python/pytest-codeblocks/Manifest
@@ -0,0 +1 @@
+DIST pytest-codeblocks-0.9.0.tar.gz 6590 BLAKE2B 34d1c72a891d2f2f1d98c4238322d888a48b286d628e3738043d16a59a75b3bd15b29e31c554a83508d9af31caf1b526e3c535a243bcf77c8d77f9bf5be69f5b SHA512 834002c4e9c8ad36baa9a4ed494fe28cf09460e0ee5a0a3d8d111cb0bd8ca4ed3c784a047901bc67984e7892f931b5644c1ea68112e4d9dda514a20e048b3d11
diff --git a/dev-python/pytest-codeblocks/metadata.xml b/dev-python/pytest-codeblocks/metadata.xml
new file mode 100644
index 000000000000..7911d01e1748
--- /dev/null
+++ b/dev-python/pytest-codeblocks/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nschloe/pytest-codeblocks</remote-id>
+ <remote-id type="pypi">pytest-codeblocks</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/pytest-codeblocks/pytest-codeblocks-0.9.0.ebuild b/dev-python/pytest-codeblocks/pytest-codeblocks-0.9.0.ebuild
new file mode 100644
index 000000000000..e065c9d437e9
--- /dev/null
+++ b/dev-python/pytest-codeblocks/pytest-codeblocks-0.9.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=pytest-codeblocks-${PV}
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="https://github.com/nschloe/pytest-codeblocks/"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest