summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-29 05:02:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-29 05:16:22 +0200
commit8430017a54c392f896235d5752599d5aca132a50 (patch)
tree353c800a70ecbcfa1c455bca7c04faffcbc75b06 /dev-python/pytest-home
parentdev-python/jaraco-vcs: Bump to 2.3.0 (diff)
downloadgentoo-8430017a54c392f896235d5752599d5aca132a50.tar.gz
gentoo-8430017a54c392f896235d5752599d5aca132a50.tar.bz2
gentoo-8430017a54c392f896235d5752599d5aca132a50.zip
dev-python/pytest-home: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-home')
-rw-r--r--dev-python/pytest-home/Manifest1
-rw-r--r--dev-python/pytest-home/pytest-home-0.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-home/Manifest b/dev-python/pytest-home/Manifest
index 96f9ab0e2ae5..a3cd5d9c8cce 100644
--- a/dev-python/pytest-home/Manifest
+++ b/dev-python/pytest-home/Manifest
@@ -1 +1,2 @@
DIST pytest-home-0.5.1.tar.gz 7596 BLAKE2B 3e0ac21a35bff15e652d710bab0c59855c9beda9a1aa32ca5e3aa9e659dabb5a09bc0e93c56f280e859a1d50159f6e56aaf69ec64ee5268a1a93871bca3b3a23 SHA512 6b3ab71f48135d7fe3e0279de598e8067bfeb1f3295d4ab947ff703e8c8c6b61d827ce30f86da15b854a09b813105e459eed02af19da22debd25df20759759b8
+DIST pytest_home-0.6.0.tar.gz 8073 BLAKE2B 13760c97f2466eaf4d6b4cd5630bc7c1129d86049a9083b13fa389a8c8e47de62e2b7b71bafd6348cf6fde8a246b9fe32be6c03d45b7f0bcdef565a95b95fae6 SHA512 8abb4d3f5ff9c5b90ed5cea3b80c877899c68a53d424cc6785a5664b7df1fa7afcaf435c3f752ee74d911dc7ceb4c95e970d25dfad9225538737779ad0b9bcf8
diff --git a/dev-python/pytest-home/pytest-home-0.6.0.ebuild b/dev-python/pytest-home/pytest-home-0.6.0.ebuild
new file mode 100644
index 000000000000..9b96b2c5bf9c
--- /dev/null
+++ b/dev-python/pytest-home/pytest-home-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Home directory fixtures"
+HOMEPAGE="
+ https://github.com/jaraco/pytest-home/
+ https://pypi.org/project/pytest-home/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_home.fixtures
+ epytest
+}