summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-12-31 07:20:14 -0800
committerZac Medico <zmedico@gentoo.org>2016-12-31 07:22:45 -0800
commitba8a264fcf6ca2ce3eda03e601f906cb7f8a3f95 (patch)
tree6c1d9f6908fa5e55dfbad73bdc796710cc35cdc9 /dev-python/pytest-mock
parentapp-text/writerperfect: Remove old (diff)
downloadgentoo-ba8a264fcf6ca2ce3eda03e601f906cb7f8a3f95.tar.gz
gentoo-ba8a264fcf6ca2ce3eda03e601f906cb7f8a3f95.tar.bz2
gentoo-ba8a264fcf6ca2ce3eda03e601f906cb7f8a3f95.zip
dev-python/pytest-mock: version bump to 1.5.0
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.5.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 42731d1e74e0..d28aaa0aa4bf 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1 +1,2 @@
DIST pytest-mock-1.2.zip 19461 SHA256 f78971ed376fcb265255d1e4bb313731b3a1be92d7f3ecb19ea7fedc4a56fd0f SHA512 9b87c72e9895a16d4829229a070ba2b8143be894dfbc804b1e882eb2cc5843d8da9db258b5a2b9f8ae6738d9d612dbf1bec16790c5f99c27d9f7554cb676f852 WHIRLPOOL 470832b4df4a9392b0cfcbba96b2a52379d7111af0236f5dbe4e22f4e303da248bf2f936b3b66ae0ff3a197f3c87b0419c54c115fe5c6543e255f11666d3031d
+DIST pytest-mock-1.5.0.tar.gz 17199 SHA256 782f23f227874bac4cee878637c2af8efdd2c34c48fcbf9e79b00a0872056ffb SHA512 5b5acb3ae3040d37768692a5289be269d8e12a6188a2dddefb136bdb99f847bedee525d59ac49886a6a27032b672e442ee256410174777675bf92fc82505f807 WHIRLPOOL 7c9c2617944dbf02cce356d12650d89372db252bdf79b92db304bcb1337858a38ae4b9b640210190338feccf4de0cbd64ad1a2d7ffc411c9184e1cd09dd7ec17
diff --git a/dev-python/pytest-mock/pytest-mock-1.5.0.ebuild b/dev-python/pytest-mock/pytest-mock-1.5.0.ebuild
new file mode 100644
index 000000000000..a73076e25b9b
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-1.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/mock[python_targets_python2_7]
+ )
+ python_targets_pypy? (
+ dev-python/mock[python_targets_pypy]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test test_pytest_mock.py || die
+}