summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-07-10 15:43:41 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-07-10 16:30:31 -0500
commitdddd59a890daed39a20590a258367194c196e6cb (patch)
treede19237fd1d3e5477c6ee4a71ee37a61a5fc3f45 /dev-python/pytest-subtesthack
parentdev-python/pytest-subtesthack: enable py3.10 and disable py3.7 (diff)
downloadgentoo-dddd59a890daed39a20590a258367194c196e6cb.tar.gz
gentoo-dddd59a890daed39a20590a258367194c196e6cb.tar.bz2
gentoo-dddd59a890daed39a20590a258367194c196e6cb.zip
dev-python/pytest-subtesthack: drop 0.1.1
The tests pass locally with 0.1.2 with all implementations, so the test failure bug seems no longer relevant. Closes: https://bugs.gentoo.org/738262 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/Manifest1
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild32
2 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/pytest-subtesthack/Manifest b/dev-python/pytest-subtesthack/Manifest
index 831610c75eb0..ec39bdad2850 100644
--- a/dev-python/pytest-subtesthack/Manifest
+++ b/dev-python/pytest-subtesthack/Manifest
@@ -1,2 +1 @@
-DIST pytest-subtesthack-0.1.1.tar.gz 2410 BLAKE2B 3d41950ad46bb07da145db7f88eba7eb34a2bbb99273f47d2443cae5ab0e11737f1c2fe81bf473180178b2ad9e55b252c7717846f1b010cc58fb1bf61380d003 SHA512 0bf6425b535e65dc7f06f74493d10fbb6451e78a817174638661d7525f39f092f67db8da010228cbd54b400485e71e443118f91ebef660b9c00d2b354062a55f
DIST pytest-subtesthack-0.1.2.tar.gz 2669 BLAKE2B f1f5a052f9418732de4a97ff438d280d177860439e667e29ff0d0503740e009c88046b5ba859884e5fa9e958ea1be7388d7fc6838c19e44075ab0ef757ee41c7 SHA512 ddb7b0c27f912bec31e58ddc54930e229755df8980d146c861f7f1c766ae742b4f1552117d89638bdbd443f22890262320a56565954ebc6deeae6184f459a5a8
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
deleted file mode 100644
index 1c2580a1e3e2..000000000000
--- a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
-HOMEPAGE="https://github.com/untitaker/pytest-subtesthack/"
-# pypi tarball misses tests
-SRC_URI="https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}