summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-10-05 17:48:37 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-10-07 11:11:15 -0700
commitb9edba5ffef49372d3042da5e8fe2ca733caac97 (patch)
treea02615005677f3ed8f80443b3285d0f4f0471853 /dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild
parentdev-python/pytest-cov: Version bump, adds a new pkg dep (diff)
downloadgentoo-b9edba5ffef49372d3042da5e8fe2ca733caac97.tar.gz
gentoo-b9edba5ffef49372d3042da5e8fe2ca733caac97.tar.bz2
gentoo-b9edba5ffef49372d3042da5e8fe2ca733caac97.zip
dev-python/pytest-xdist: Version bump, adds new deps
Drop keywords due to new deps. Package-Manager: portage-2.3.1_p8
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild
new file mode 100644
index 000000000000..5541df47238a
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-xdist https://github.com/pytest-dev/pytest-xdist2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/execnet-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/readme[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ find -name __pycache__ -exec rm -r '{}' + || die
+ py.test -vv -x || die "Tests failed under ${EPYTHON}"
+}