summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2017-08-15 19:39:45 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-08-18 17:14:34 +0200
commit87ce2aed9ad846a077c08c48018b29843f79e520 (patch)
treeef8d250f1e143af64b4afb02e2bcbdc18f593ed0 /dev-python/python-bugzilla
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-87ce2aed9ad846a077c08c48018b29843f79e520.tar.gz
gentoo-87ce2aed9ad846a077c08c48018b29843f79e520.tar.bz2
gentoo-87ce2aed9ad846a077c08c48018b29843f79e520.zip
dev-python/python-bugzilla: Bump version to v2.1.0
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/python-bugzilla')
-rw-r--r--dev-python/python-bugzilla/Manifest1
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
index 5817a4eb5e92..744681caddbd 100644
--- a/dev-python/python-bugzilla/Manifest
+++ b/dev-python/python-bugzilla/Manifest
@@ -1 +1,2 @@
DIST python-bugzilla-1.2.2.tar.gz 76026 SHA256 e4606c325960f9e3eb90aac26014348c96160d77bbee09b7c31c211d38433922 SHA512 bb4ce43ffbf054097bd537404861848dd4ff5883fa63f156dfa90bea9f2e89cfaf0670980ec290a3d9c90cee268709b914e8bd5bd38b7f2e29c8d7fbd0215ac2 WHIRLPOOL cd37177dd5ebcf3016ab870d76e9a2bb655c3d6d0ef8884820d1646daad9f364c71c62d156bb3f60c5a4fffc5b92255f9db9da9c9771f2c95b7494fd294bc75a
+DIST python-bugzilla-2.1.0.tar.gz 78791 SHA256 f3145ab86c299389f3686fc44bb7c8b70eb1a9ccd4a7bafe578b5c4d450c8250 SHA512 40dd331e2dbb4d70ce6d356eb800d6242ef9878112310087761c8dccb7f05b259f0f5fdee6821713a84c68f1e5f9e0bb6ee45542bc385f00822b97344371239e WHIRLPOOL 4af78e7739a9276c0226d95ff25ba47b89e46de8539f864edae7e2678a90b6defe85684c36df0dc3490fca3f151cc917394bf4c14e95666c488c5979af8be1d8
diff --git a/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
new file mode 100644
index 000000000000..05c40aa71118
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage
+ dev-python/pep8
+ )
+"
+
+python_test() {
+ "${EPYTHON}" ./setup.py test
+}