summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2019-08-14 17:29:09 +0200
committerAaron W. Swenson <titanofold@gentoo.org>2019-10-17 18:15:09 -0400
commit7033cf03516f31603586777683c5d6a65448cd3d (patch)
tree86b64e525c05eba0adb53f965ca93f26ba7c069a /dev-python/python-dateutil
parentwww-client/opera: Old (diff)
downloadgentoo-7033cf03516f31603586777683c5d6a65448cd3d.tar.gz
gentoo-7033cf03516f31603586777683c5d6a65448cd3d.tar.bz2
gentoo-7033cf03516f31603586777683c5d6a65448cd3d.zip
dev-python/python-dateutil: bump 2.8.0
also bump EAPI to 7 Signed-off-by: David Heidelberg <david@ixit.cz> Closes: https://github.com/gentoo/gentoo/pull/12705 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/python-dateutil')
-rw-r--r--dev-python/python-dateutil/Manifest1
-rw-r--r--dev-python/python-dateutil/python-dateutil-2.8.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/python-dateutil/Manifest b/dev-python/python-dateutil/Manifest
index d4b7691de6b0..46398b25f552 100644
--- a/dev-python/python-dateutil/Manifest
+++ b/dev-python/python-dateutil/Manifest
@@ -4,3 +4,4 @@ DIST python-dateutil-2.7.2.tar.gz 298000 BLAKE2B 4091108b125eb080809c74cdb53daa2
DIST python-dateutil-2.7.3.tar.gz 302871 BLAKE2B 8b6cff6f977d52b64665f33d10513a638addada91a00192eb1f522aa9b239d5fb051bff3cfb837871ea61d7ab69994cfe5b42bb3b00851b5f15368c26db06fd7 SHA512 6b9973fa7db69d931bc6e772201c67bb7bbfa693ba35484d34960bd7e6227f2a2343df814a9fdbbff253e750299c48e7cdb2a609bf4522595df8a7fc595784fd
DIST python-dateutil-2.7.4.tar.gz 302229 BLAKE2B e2a43d8587f895a9a72ca5ab5c18a5c471497c8f8e89459450219e9f5ecb55223f36f219d77df8da4c04d55fb5feb3a17f9a5c2318c077dac4307da7c0bd9645 SHA512 3b02b397e3138dc755f34a2f7a50464f96a73b7be1f335ce7da3fa99e6d59f34a0643dfb1c933d4ef4fbaab88364fab6e760e4b1e7040b8cbbfebdd75e7e9a4f
DIST python-dateutil-2.7.5.tar.gz 316043 BLAKE2B 29511f7e484c369084d696f45a07e01e096e7b1114f982026f8df71d569eea30d657956d3e53725ad57564c1e445414c2ed543e3e6d2dd89902d7838cbb9e6fe SHA512 762752191d584a3995b55bbcfadc829261a263e0e6515a52db2fc32157bf0b3f96f787107c49bbd77cab9ce7e3f692ab3e8f392260fc18e6456b74eb190b44d3
+DIST python-dateutil-2.8.0.tar.gz 327134 BLAKE2B 6525eee57aeaef3c588413210df7c1ad3627a380c6e44af78e9acc9abea523b29e8d9afec495f8d1e585d25d32ab82e6e28bf93dca148893d2e6a533e1f4ce47 SHA512 ec7da86203572582f883a4686acf8a732a2de4f396d809057eb51b2c60dbca5623a7fa90c2c0618c281a2282c60841739bd837731a51cc876f4ff369297f2f81
diff --git a/dev-python/python-dateutil/python-dateutil-2.8.0.ebuild b/dev-python/python-dateutil/python-dateutil-2.8.0.ebuild
new file mode 100644
index 000000000000..172252195d85
--- /dev/null
+++ b/dev-python/python-dateutil/python-dateutil-2.8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensions to the standard Python datetime module"
+HOMEPAGE="
+ https://dateutil.readthedocs.org/
+ https://pypi.org/project/python-dateutil
+ https://github.com/dateutil/dateutil/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ sys-libs/timezone-data
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/0001-zoneinfo-Get-timezone-data-from-system-tzdata.patch
+ )
+
+ # don't install zoneinfo tarball
+ sed -i '/package_data=/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}