summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-24 07:50:42 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-24 09:49:24 +0100
commitc7a164a1e738132cb5db00cdd6a8343e164aba74 (patch)
treea49d1bfac477f265ff4f9127f740171f34c5200b /dev-python/python-dbusmock
parentdev-python/pandas: Bump to 2.2.1 (diff)
downloadgentoo-c7a164a1e738132cb5db00cdd6a8343e164aba74.tar.gz
gentoo-c7a164a1e738132cb5db00cdd6a8343e164aba74.tar.bz2
gentoo-c7a164a1e738132cb5db00cdd6a8343e164aba74.zip
dev-python/python-dbusmock: Bump to 0.31.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest1
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.31.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 7160f190457c..ef1273553270 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1 +1,2 @@
DIST python-dbusmock-0.30.2.tar.gz 98188 BLAKE2B bfcac761933c2d433ddc7b53ca87ceb395dba23b73fc4478e0317cf1da6693b3b55cd7d5ca814425d74714f8b7544255f07a536fe7c1a1949dee30996a2761a0 SHA512 a34c4660fe50b9551274626b19959dbe985e112429d2eb68811f3cc37cc017f8171eac2e2b8c262874678e24f7fb3d1f39410cd977b59f501973de19b6ca3a13
+DIST python-dbusmock-0.31.1.tar.gz 98739 BLAKE2B 623aa336c66ad1743d1b86421184c13d647970ffe1a7ffbc2e100c179fb3af98846c96f0a8baccfb9a1f47aa2e380d0bff91c17f967d9c798a97a5fef43bc376 SHA512 5d409e979046cf301c5f8604b43c67abba111315d40e54b59cc5ff6e8fe3bb006591fdac877f750b3a0d56f840337f136b99dda9237de1b00718ef85a3bfcf7b
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.31.1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.31.1.ebuild
new file mode 100644
index 000000000000..4915685b8472
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.31.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ distutils-r1_python_test
+}