summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2018-03-28 23:01:20 -0400
committerMike Frysinger <vapier@gentoo.org>2018-03-28 23:01:20 -0400
commite63c06317d1275632dd197c6ba02ee3f9d58908c (patch)
tree8c23166e5f2cbde4ad314033fb4b32525aebf3cf /dev-python/python-gflags
parentdev-python/fasteners: add arm love to 0.14.1 (diff)
downloadgentoo-e63c06317d1275632dd197c6ba02ee3f9d58908c.tar.gz
gentoo-e63c06317d1275632dd197c6ba02ee3f9d58908c.tar.bz2
gentoo-e63c06317d1275632dd197c6ba02ee3f9d58908c.zip
dev-python/python-gflags: version bump to 3.1.2
Diffstat (limited to 'dev-python/python-gflags')
-rw-r--r--dev-python/python-gflags/Manifest1
-rw-r--r--dev-python/python-gflags/python-gflags-3.1.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-gflags/Manifest b/dev-python/python-gflags/Manifest
index b385f4609caf..14b179d6f92e 100644
--- a/dev-python/python-gflags/Manifest
+++ b/dev-python/python-gflags/Manifest
@@ -1 +1,2 @@
DIST python-gflags-3.1.1.tar.gz 52633 BLAKE2B 78966a7ffd924dcb16b4c6459d10cb06b9494150887433fec1e32e1b454f151386d4024f3ba1d307f756781128224c8106539480d9291dcc2ed82e85c8eef36f SHA512 28009cdc09b94b416af5237d3897d6ab516cc3b6a3eed18a31adb8c199f31a8c7d07b1d69794cb37de84b50eefbde1de57f9f0afaeac0a4747b352f4024ef12c
+DIST python-gflags-3.1.2.tar.gz 52093 BLAKE2B 4275b43ecf2c58f76fee0b1ff4645eb3176a9ae3b68fdd4a059c2f6f659ca1d9b6e4fad152a2fa48f1eb22c467dbc006835c241c21f89c0ca92367e484f34c6f SHA512 7a3c08b6b212cdb9cb7feaa48e3875d1204a4b3a57182508a078331565f70509d00c315400fa0316dbf61ed4d6a6a04ca8c1a2303567d37650d8dfbb329e2f6c
diff --git a/dev-python/python-gflags/python-gflags-3.1.2.ebuild b/dev-python/python-gflags/python-gflags-3.1.2.ebuild
new file mode 100644
index 000000000000..fbe985dcaf55
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-3.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Python argument parsing library"
+HOMEPAGE="https://github.com/google/python-gflags"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-script-install.patch
+)
+
+python_test() {
+ # note: each test needs to be run separately, otherwise they fail
+ "${PYTHON}" -m gflags._helpers_test -v || die
+ "${PYTHON}" -m gflags.flags_formatting_test -v || die
+ "${PYTHON}" -m gflags.flags_unicode_literals_test -v || die
+}