summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-21 11:32:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 18:17:52 +0100
commit068a91a8a87f581d80f3ca1aba73fdbc5bf40ae9 (patch)
treec556c4727ffa253f974b538e50eea4dc34dc1d3d /dev-python/python-ly
parentdev-python/python-ly: drop 0.9.6 (diff)
downloadgentoo-068a91a8a87f581d80f3ca1aba73fdbc5bf40ae9.tar.gz
gentoo-068a91a8a87f581d80f3ca1aba73fdbc5bf40ae9.tar.bz2
gentoo-068a91a8a87f581d80f3ca1aba73fdbc5bf40ae9.zip
dev-python/python-ly: enable py3.11
- python 3.11 support enabled - few style changes common to dev-python category - remove comment about missing tests in pypi tarball, because we use sources from github - add dev-python/lxml test dependency, however, tests are still restricted, because I failed to make them work properly. My attempt is described in upstream issue [1]. [1] https://github.com/frescobaldi/python-ly/issues/153 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29702 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-ly')
-rw-r--r--dev-python/python-ly/python-ly-0.9.7.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/dev-python/python-ly/python-ly-0.9.7.ebuild b/dev-python/python-ly/python-ly-0.9.7.ebuild
index 7dc8c9f964f1..ea877488ed31 100644
--- a/dev-python/python-ly/python-ly-0.9.7.ebuild
+++ b/dev-python/python-ly/python-ly-0.9.7.ebuild
@@ -4,13 +4,18 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Tool and library for manipulating LilyPond files"
-HOMEPAGE="https://github.com/frescobaldi/python-ly https://pypi.org/project/python-ly/"
-# No tests in pypi tarball
-SRC_URI="https://github.com/frescobaldi/python-ly/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/frescobaldi/python-ly/
+ https://pypi.org/project/python-ly/
+"
+SRC_URI="
+ https://github.com/frescobaldi/python-ly/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="GPL-2+"
SLOT="0"
@@ -18,4 +23,10 @@ KEYWORDS="amd64 x86"
RESTRICT="test"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
distutils_enable_tests pytest