summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-07 11:01:22 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-07 13:00:00 +0100
commit960c6c4c5d88fb65ff85ccfb8cf74b1337462f0d (patch)
tree2a9f7c7dd64207470976c4e16bf99c1506148151 /dev-python/python-ptrace
parentdev-perl/HTML-Parser: Version bump (diff)
downloadgentoo-960c6c4c5d88fb65ff85ccfb8cf74b1337462f0d.tar.gz
gentoo-960c6c4c5d88fb65ff85ccfb8cf74b1337462f0d.tar.bz2
gentoo-960c6c4c5d88fb65ff85ccfb8cf74b1337462f0d.zip
dev-python/python-ptrace: Chop DESCRIPTION to 80 chars
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild b/dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild
index a598d06c02f6..a3ce1fca47ef 100644
--- a/dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild
+++ b/dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)"
+DESCRIPTION="A debugger using ptrace (Linux, BSD and Darwin system call to trace processes)"
HOMEPAGE="https://bitbucket.org/haypo/python-ptrace/ https://pypi.python.org/pypi/python-ptrace"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -25,6 +26,6 @@ python_test() {
python_install_all() {
use examples && local EXAMPLES=( examples/. )
# doc folder missing key files to effect a proper doc build
- use doc && local DOCS=( README doc/* )
+ use doc && local DOCS=( README doc/. )
distutils-r1_python_install_all
}