summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-26 06:14:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-26 06:39:16 +0100
commit02e843eab09c000cce445db27c4cb3bff70b20a1 (patch)
tree70c21f0e94032391cdd8c5e54020cd7497420c7d /dev-python/python-slugify
parentdev-python/vcrpy: Bump to 6.0.1 (diff)
downloadgentoo-02e843eab09c000cce445db27c4cb3bff70b20a1.tar.gz
gentoo-02e843eab09c000cce445db27c4cb3bff70b20a1.tar.bz2
gentoo-02e843eab09c000cce445db27c4cb3bff70b20a1.zip
dev-python/python-slugify: Bump to 8.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-8.0.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 977aa7ea4523..218cfcb77b99 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1 +1,2 @@
DIST python-slugify-8.0.1.gh.tar.gz 13574 BLAKE2B 24fe3dc74f2a867e81bfbb9eac4a1db59a185ddfaf0f2f80cb50d5f06b2061ce28d23ba09ffd214dba26563d1ef37900d016d75dde7a7c35fa756cf49f51b9c2 SHA512 721089244c90f784e49259ee70caa0908d8523c2cf42c8fd57804a73017a815311a9cc9981c1f70a8c2f7cd7e01d77eedf8f9bd3c9d5c55ac4d5f72dbe512b34
+DIST python-slugify-8.0.2.gh.tar.gz 13891 BLAKE2B d05e5a5095264a6aec3692dd651f47cc4cfe2580f5bf604531c0c89199d6b350591dfe0238b9ebd025ccf5b6c6e660a75da76d679500efb942f9f9c7aaefba7d SHA512 7de28f06e8f23d46b0be3ede4f1e6fb791f95fae6c7afd94562418a34d3be6a5c4aabc2ef6a8eca353298fd12ea87c71e35e0cd4b6f17b4fee07356c4905a061
diff --git a/dev-python/python-slugify/python-slugify-8.0.2.ebuild b/dev-python/python-slugify/python-slugify-8.0.2.ebuild
new file mode 100644
index 000000000000..53b7da22bd82
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-8.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/text-unidecode[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest