summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 22:01:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 22:30:12 +0100
commitdc1fc6a9f672d12633f7417cb11f41d351e9e408 (patch)
tree9725e7ee39695fcb79b47e733d6dfab094287c17 /dev-python/python-swiftclient
parentdev-python/test_server: Bump to 0.0.35 (diff)
downloadgentoo-dc1fc6a9f672d12633f7417cb11f41d351e9e408.tar.gz
gentoo-dc1fc6a9f672d12633f7417cb11f41d351e9e408.tar.bz2
gentoo-dc1fc6a9f672d12633f7417cb11f41d351e9e408.zip
dev-python/python-swiftclient: Bump to 3.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/Manifest1
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index 4d88d9fe6183..347fdbcaa033 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1 +1,2 @@
DIST python-swiftclient-3.13.0.tar.gz 201575 BLAKE2B b098f3980590a562278417f572a762064fdc04c643a50767bab15f07679148854d373e0418f9996327fca6fca4ab53b4363b1d681706f96d0c25925bb84a6525 SHA512 b228337d1ecd3adc1bbb9f9ac5bd16cc068feadaf4faf398fd84c2a05ee226fa2dd5b4af639229b62271a4546f6db3e02bc0479288e0269745b1a9ff82e6c841
+DIST python-swiftclient-3.13.1.tar.gz 201632 BLAKE2B f7cdf7e30ea333f568c8ef06d065b18908b1e4c9f8f0b777906bdfa8f6c998292136859f62f0d2e58465ee9eec3452d29e3e69ed7567a07bfcddcf6ad1bf321c SHA512 bd958fb8cfde6f72bcf82d381ce06e0e94c383aee85abab5a111c408bacf2578eaf53244ae12438d4454fcefe8d867246aef952d1d15012364e20817cc90042d
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild b/dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild
new file mode 100644
index 000000000000..42e29c100389
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ distutils-r1_python_prepare_all
+}