summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 06:05:49 +0000
committerSam James <sam@gentoo.org>2023-02-17 06:22:18 +0000
commit279a672d653d59114622429a5113cecfd0990d1a (patch)
treed19c5c23bca0cf46f898b7b7aee34902f8d4c0f2 /dev-python/pyusb/pyusb-1.2.1-r1.ebuild
parentdev-python/pyusb: enable py3.11, use pypi.eclass, fix w/ newer setuptools (diff)
downloadgentoo-279a672d653d59114622429a5113cecfd0990d1a.tar.gz
gentoo-279a672d653d59114622429a5113cecfd0990d1a.tar.bz2
gentoo-279a672d653d59114622429a5113cecfd0990d1a.zip
dev-python/pyusb: PEP517
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyusb/pyusb-1.2.1-r1.ebuild')
-rw-r--r--dev-python/pyusb/pyusb-1.2.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyusb/pyusb-1.2.1-r1.ebuild b/dev-python/pyusb/pyusb-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..9f3ac1f4c29c
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.2.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="https://pyusb.github.io/pyusb/ https://pypi.org/project/pyusb/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+DOCS=( README.rst docs/tutorial.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-setuptools.patch
+)
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
+}