summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-27 04:39:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-27 05:21:16 +0200
commit4a623475b3c5187b50f8cfc5755c5cca777a00f2 (patch)
treeba608ee0062d768b4f74aca33cb8c18c07080e47 /dev-python/pywayland
parentdev-util/stripe-mock: Bump to 0.168.0 (diff)
downloadgentoo-4a623475b3c5187b50f8cfc5755c5cca777a00f2.tar.gz
gentoo-4a623475b3c5187b50f8cfc5755c5cca777a00f2.tar.bz2
gentoo-4a623475b3c5187b50f8cfc5755c5cca777a00f2.zip
dev-python/pywayland: Bump to 0.4.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pywayland')
-rw-r--r--dev-python/pywayland/Manifest1
-rw-r--r--dev-python/pywayland/pywayland-0.4.16.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pywayland/Manifest b/dev-python/pywayland/Manifest
index 979b3c791fb9..8f915db59f6d 100644
--- a/dev-python/pywayland/Manifest
+++ b/dev-python/pywayland/Manifest
@@ -1 +1,2 @@
DIST pywayland-0.4.15.gh.tar.gz 61084 BLAKE2B 2417aa57942f5a7810db3525d16070ed81613bd1ab8f864a95e9f1835f9793348ad1afd2dbaeed2bb08f5bcb58777ab545f8ef7cb70903703c89998095724f8c SHA512 c45d2a24c487cf1785b7bc488808157e2dcae630438c289864df615c98278e7c03de21431fa622e0917713130f5583ff5cb3181c0a7f595cebba2cdeec36a7cf
+DIST pywayland-0.4.16.gh.tar.gz 61058 BLAKE2B 4b299fe1b3067e2e222012db921b4ae5fdfd103b0ca2b796522236b6b8b2ffc1e54ba8c97d30970cb5df35c9da18ca217ea5d97a37b11d7112d93c59a1df164f SHA512 1098e0ae88ffc874d1e49f6441f06db05d1bfebead06d65e1214d69542b9ada0ec45bfccd6fd11dd188b2ebcf3d0ac2a2370927af8a0838f4e683ec50fc5e01a
diff --git a/dev-python/pywayland/pywayland-0.4.16.ebuild b/dev-python/pywayland/pywayland-0.4.16.ebuild
new file mode 100644
index 000000000000..3741622e025e
--- /dev/null
+++ b/dev-python/pywayland/pywayland-0.4.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Python bindings for the libwayland library"
+HOMEPAGE="
+ https://pywayland.readthedocs.io/en/latest/
+ https://github.com/flacjacket/pywayland
+ https://pypi.org/project/pywayland/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywayland/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/wayland
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needed for tests (XDG_RUNTIME_DIR)
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -rf pywayland || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}