summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-16 07:57:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-16 12:22:03 +0200
commitb66a54af2765ee30275a377f02217db6f45a4dd2 (patch)
tree5623370426aa3471d2f1e90ecbf443e79897d754 /dev-python/pyzmq
parentgames-arcade/cdogs-sdl: add 2.1.0 (diff)
downloadgentoo-b66a54af2765ee30275a377f02217db6f45a4dd2.tar.gz
gentoo-b66a54af2765ee30275a377f02217db6f45a4dd2.tar.bz2
gentoo-b66a54af2765ee30275a377f02217db6f45a4dd2.zip
dev-python/pyzmq: Bump to 26.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/pyzmq-26.0.0.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 1e66651c578f..d00fdbd0256b 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1 +1,2 @@
DIST pyzmq-25.1.2.gh.tar.gz 391272 BLAKE2B 80814704e7ea08d407859c1d71338f6ea283efcd1f3994155334aa5b60c4b6cd89167de8c78d19f8efdbeb5f4071f7b5954ea911eb6e7fbb48a0087b86579cab SHA512 b146a6dbce7cbbe2eb1da7ebd64e463067354f1566cdb4ff634b59bbb6d65e16263b6acb2d101a4ea53f870be5c753c9a12f9cc37bc5a81236681ea4fda6c56b
+DIST pyzmq-26.0.0.gh.tar.gz 267825 BLAKE2B 4a9c85ffded107f4a24f49dcecfd00f0a902021f1921cdd81bf98269ecb19cdd6e4718c6b68ebb9c6d94eb6ba1a2878ea953063b076093b2094849b59977fa44 SHA512 b9ac2a8520bab63035b36ed7e8759d459ad933eb1316a6278b29f413e5655afcca9282bc8ebcfa0f02b893daf344b5b5b5b704cd3089614fd3bdc13ff735db02
diff --git a/dev-python/pyzmq/pyzmq-26.0.0.ebuild b/dev-python/pyzmq/pyzmq-26.0.0.ebuild
new file mode 100644
index 000000000000..e360778f49ba
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-26.0.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=scikit-build-core
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://zeromq.org/languages/python/
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/
+"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="drafts"
+
+# There are additional test failures if zeromq has the draft api enabled, but pyzmq has it disabled.
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts=]
+"
+# It uses cffi backend for pypy, cython backend for cpython
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/cython-3.0.0[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: Package enum_tools
+# distutils_enable_sphinx docs/source \
+# dev-python/numpydoc \
+# dev-python/sphinx-rtd-theme \
+# dev-python/myst-parser
+
+src_configure() {
+ export ZMQ_DRAFT_API=$(usex drafts '1' '0')
+
+ # TODO: remove this when we update the eclass
+ export SKBUILD_INSTALL_STRIP=false
+}
+
+src_test() {
+ # need to move them around to make EPYTEST_IGNORE work cleanly
+ # with tests-in-package and extension modules
+ mv zmq/tests . || die
+ rm -r zmq || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Avoid dependency on mypy
+ tests/test_mypy.py
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # not implemented in cffi variant?
+ tests/test_draft.py::TestDraftSockets
+ )
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # avoid large to reduce memory consumption
+ epytest -p asyncio -p rerunfailures tests -m "not large"
+}