summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-31 10:37:32 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-31 10:46:06 +0100
commit727d085341617dd20e5de5733b3f476f4897f9b7 (patch)
tree3d1eedebf5f72ec56134e08a9e5900fd7b43099f /dev-python/quart-trio
parentwww-client/microsoft-edge-dev: crank copyright (diff)
downloadgentoo-727d085341617dd20e5de5733b3f476f4897f9b7.tar.gz
gentoo-727d085341617dd20e5de5733b3f476f4897f9b7.tar.bz2
gentoo-727d085341617dd20e5de5733b3f476f4897f9b7.zip
dev-python/quart-trio: New package, v0.11.1
New test dependency of dev-python/urllib3. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quart-trio')
-rw-r--r--dev-python/quart-trio/Manifest1
-rw-r--r--dev-python/quart-trio/metadata.xml13
-rw-r--r--dev-python/quart-trio/quart-trio-0.11.1.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/quart-trio/Manifest b/dev-python/quart-trio/Manifest
new file mode 100644
index 000000000000..ca8de06ec426
--- /dev/null
+++ b/dev-python/quart-trio/Manifest
@@ -0,0 +1 @@
+DIST quart-trio-0.11.1.gh.tar.gz 18568 BLAKE2B faabf4204a82dcc70e41d1d1ec7171c89386f2e40979c20501890d9bc27eb2af693bc791a9015a9c4c676a5e25ec69dc4975a0cd09987cd14f699a04442d54da SHA512 8ea20c36c772eff3e2b0a83a4c325cd223c19b3d7e1e51e7378897bd11479db2c8015d2e8c4713721070fc413f42b19f844a3966a0d06d299439cf514b0b3291
diff --git a/dev-python/quart-trio/metadata.xml b/dev-python/quart-trio/metadata.xml
new file mode 100644
index 000000000000..0a22f1b2a556
--- /dev/null
+++ b/dev-python/quart-trio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- please remove python@ if tests do not work -->
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pgjones/quart-trio</remote-id>
+ <remote-id type="pypi">quart-trio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/quart-trio/quart-trio-0.11.1.ebuild b/dev-python/quart-trio/quart-trio-0.11.1.ebuild
new file mode 100644
index 000000000000..fff0e201a851
--- /dev/null
+++ b/dev-python/quart-trio/quart-trio-0.11.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Quart extension to provide trio support"
+HOMEPAGE="
+ https://github.com/pgjones/quart-trio/
+ https://pypi.org/project/quart-trio/
+"
+# no tests in sdist, as of 0.11.1
+SRC_URI="
+ https://github.com/pgjones/quart-trio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/exceptiongroup-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/quart-0.19[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p trio
+}