summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-16 05:06:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-16 05:06:49 +0100
commit294c2f6b760665dcbdc20908f91bafcd6aa3bd85 (patch)
tree069a36ff675d8f948b9a70394b9e4825b303a465 /dev-python/rapidfuzz/rapidfuzz-2.13.2.ebuild
parentdev-python/rope: Use pypi.eclass (diff)
downloadgentoo-294c2f6b760665dcbdc20908f91bafcd6aa3bd85.tar.gz
gentoo-294c2f6b760665dcbdc20908f91bafcd6aa3bd85.tar.bz2
gentoo-294c2f6b760665dcbdc20908f91bafcd6aa3bd85.zip
dev-python/rapidfuzz: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rapidfuzz/rapidfuzz-2.13.2.ebuild')
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-2.13.2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/rapidfuzz/rapidfuzz-2.13.2.ebuild b/dev-python/rapidfuzz/rapidfuzz-2.13.2.ebuild
deleted file mode 100644
index 3b7d7955ca05..000000000000
--- a/dev-python/rapidfuzz/rapidfuzz-2.13.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# custom wrapper over setuptools
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
-HOMEPAGE="
- https://github.com/maxbachmann/RapidFuzz/
- https://pypi.org/project/rapidfuzz/
-"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-# all these are header-only libraries
-DEPEND="
- >=dev-cpp/taskflow-3.0.0
- >=dev-cpp/rapidfuzz-cpp-1.10.0
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/rapidfuzz_capi[${PYTHON_USEDEP}]
- >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # sterilize build flags
- sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
-
- distutils-r1_src_prepare
-
- export RAPIDFUZZ_BUILD_EXTENSION=1
-}