summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:51:27 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:53:00 +0300
commite11dc8047a0775289d57a11160971079e512a033 (patch)
tree30b2ff72c98e70e34b8ecbc0319245c60091c2a2 /dev-python/requests_download
parentdev-python/roman: enable py3.11 (diff)
downloadgentoo-e11dc8047a0775289d57a11160971079e512a033.tar.gz
gentoo-e11dc8047a0775289d57a11160971079e512a033.tar.bz2
gentoo-e11dc8047a0775289d57a11160971079e512a033.zip
dev-python/requests_download: EAPI=8, Use PEP517 flit
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/requests_download')
-rw-r--r--dev-python/requests_download/requests_download-0.1.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/requests_download/requests_download-0.1.2-r1.ebuild b/dev-python/requests_download/requests_download-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..aeaf9ada1e76
--- /dev/null
+++ b/dev-python/requests_download/requests_download-0.1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A convenient function to download to a file using requests"
+HOMEPAGE="https://github.com/takluyver/requests_download https://pypi.org/project/requests_download/"
+SRC_URI="https://github.com/takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+# there are no tests upstream
+RESTRICT="test"
+
+DOCS=( README.rst )