summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-07 10:47:47 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-07 10:47:47 -0700
commit8ef416db9055a1f2aa8f1f8812936c66ba348628 (patch)
tree3436fc7fff5b132f74cf8ed312da8684f97b3163 /dev-python/retry-decorator/retry-decorator-1.1.1.ebuild
parentdev-python/crcmod-1.7-r3: Add py38 (diff)
downloadgentoo-8ef416db9055a1f2aa8f1f8812936c66ba348628.tar.gz
gentoo-8ef416db9055a1f2aa8f1f8812936c66ba348628.tar.bz2
gentoo-8ef416db9055a1f2aa8f1f8812936c66ba348628.zip
dev-python/retry-decorator-1.1.1: bump, add py38, enable tests
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/retry-decorator/retry-decorator-1.1.1.ebuild')
-rw-r--r--dev-python/retry-decorator/retry-decorator-1.1.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/retry-decorator/retry-decorator-1.1.1.ebuild b/dev-python/retry-decorator/retry-decorator-1.1.1.ebuild
new file mode 100644
index 000000000000..2903f122c5fb
--- /dev/null
+++ b/dev-python/retry-decorator/retry-decorator-1.1.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Decorator for retrying when exceptions occur"
+HOMEPAGE="https://github.com/pnpnpn/retry-decorator"
+SRC_URI="https://github.com/pnpnpn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest