summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-27 11:41:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-27 11:42:46 +0200
commit63820f8920412621b247f8459d5140aa458c66da (patch)
tree6667fbf5e339465e493ee344a2c2e0ef10a0c35a /dev-python/rfc8785
parentdev-python/id: New package, v1.4.0, dep of sigstore (diff)
downloadgentoo-63820f8920412621b247f8459d5140aa458c66da.tar.gz
gentoo-63820f8920412621b247f8459d5140aa458c66da.tar.bz2
gentoo-63820f8920412621b247f8459d5140aa458c66da.zip
dev-python/rfc8785: New package, v0.1.3, dep of sigstore
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rfc8785')
-rw-r--r--dev-python/rfc8785/Manifest1
-rw-r--r--dev-python/rfc8785/metadata.xml12
-rw-r--r--dev-python/rfc8785/rfc8785-0.1.3.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/rfc8785/Manifest b/dev-python/rfc8785/Manifest
new file mode 100644
index 000000000000..584d72aa3c3c
--- /dev/null
+++ b/dev-python/rfc8785/Manifest
@@ -0,0 +1 @@
+DIST rfc8785.py-0.1.3.gh.tar.gz 14754 BLAKE2B c0fab30a49cf3d1e405bf0aa32d2ec9300841bf7517b7c633ceac8dea340d3bfc7b562fbeb77c6392660f3009ca3b36e2882b7d60ca66cadfdab1661809a218c SHA512 a7318f5c19b9d49522d66c601da2006b1978bd3ccdce9e56e6ff0c8a0efbd3b13f0014b0f69a27c1f78a17c5a4c338301606c82fa70b3d09efda9efa1f23e4e9
diff --git a/dev-python/rfc8785/metadata.xml b/dev-python/rfc8785/metadata.xml
new file mode 100644
index 000000000000..8cc2dc5c7200
--- /dev/null
+++ b/dev-python/rfc8785/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">trailofbits/rfc8785.py</remote-id>
+ <remote-id type="pypi">rfc8785</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rfc8785/rfc8785-0.1.3.ebuild b/dev-python/rfc8785/rfc8785-0.1.3.ebuild
new file mode 100644
index 000000000000..aac5c89b298d
--- /dev/null
+++ b/dev-python/rfc8785/rfc8785-0.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=rfc8785.py-${PV}
+DESCRIPTION="Pure-Python impl. of RFC 8785 (JSON Canonicalization Scheme)"
+HOMEPAGE="
+ https://github.com/trailofbits/rfc8785.py/
+ https://pypi.org/project/rfc8785/
+"
+SRC_URI="
+ https://github.com/trailofbits/rfc8785.py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest