summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-28 21:20:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-28 21:36:37 +0200
commit78611913e09491cc627973baf1bbe453e8796326 (patch)
tree0cc8f6baa15e64183b0cf0654f226a5afbc40fed /dev-python/rfc8785
parentgames-strategy/ufoai: media-libs/libsdl2 will drop the threads USE flag (diff)
downloadgentoo-78611913e09491cc627973baf1bbe453e8796326.tar.gz
gentoo-78611913e09491cc627973baf1bbe453e8796326.tar.bz2
gentoo-78611913e09491cc627973baf1bbe453e8796326.zip
dev-python/rfc8785: Bump to 0.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rfc8785')
-rw-r--r--dev-python/rfc8785/Manifest1
-rw-r--r--dev-python/rfc8785/rfc8785-0.1.4.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/rfc8785/Manifest b/dev-python/rfc8785/Manifest
index 584d72aa3c3c..5a87116eccb1 100644
--- a/dev-python/rfc8785/Manifest
+++ b/dev-python/rfc8785/Manifest
@@ -1 +1,2 @@
+DIST rfc8785-0.1.4.tar.gz 14321 BLAKE2B adc378ee0a67c2ce89cb790934c3175dfb186b7a9c5852b0d87bdf0c1acd093cdeb88af40c555f8698a21e80e51dc08484b0b710c97441cf84e58942340ad04e SHA512 d563af4905ec2b6043dc6f523bf14afaf8e2df50bf22dc2abc795a7945793f9cc3d5f7ff3d25d51436edb3df2137a5f74219f5aced3221879bb638455c38422a
DIST rfc8785.py-0.1.3.gh.tar.gz 14754 BLAKE2B c0fab30a49cf3d1e405bf0aa32d2ec9300841bf7517b7c633ceac8dea340d3bfc7b562fbeb77c6392660f3009ca3b36e2882b7d60ca66cadfdab1661809a218c SHA512 a7318f5c19b9d49522d66c601da2006b1978bd3ccdce9e56e6ff0c8a0efbd3b13f0014b0f69a27c1f78a17c5a4c338301606c82fa70b3d09efda9efa1f23e4e9
diff --git a/dev-python/rfc8785/rfc8785-0.1.4.ebuild b/dev-python/rfc8785/rfc8785-0.1.4.ebuild
new file mode 100644
index 000000000000..4e1088c577bf
--- /dev/null
+++ b/dev-python/rfc8785/rfc8785-0.1.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure-Python impl. of RFC 8785 (JSON Canonicalization Scheme)"
+HOMEPAGE="
+ https://github.com/trailofbits/rfc8785.py/
+ https://pypi.org/project/rfc8785/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest