summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-09 23:38:28 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-10 02:05:05 +0000
commit3e9b88fc840f3fcb842f37080a86132c7e853d5d (patch)
tree73be876d47aac6d4ff2959df989594aab596c6c0 /dev-python/rootpy/rootpy-0.8.3.ebuild
parentdev-python/spectral-cube: initial import (diff)
downloadgentoo-3e9b88fc840f3fcb842f37080a86132c7e853d5d.tar.gz
gentoo-3e9b88fc840f3fcb842f37080a86132c7e853d5d.tar.bz2
gentoo-3e9b88fc840f3fcb842f37080a86132c7e853d5d.zip
dev-python/rootpy: version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/rootpy/rootpy-0.8.3.ebuild')
-rw-r--r--dev-python/rootpy/rootpy-0.8.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/rootpy/rootpy-0.8.3.ebuild b/dev-python/rootpy/rootpy-0.8.3.ebuild
new file mode 100644
index 000000000000..29e6271da6e8
--- /dev/null
+++ b/dev-python/rootpy/rootpy-0.8.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="readline"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic layer on top of the ROOT framework's PyROOT bindings"
+HOMEPAGE="http://rootpy.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/root_numpy[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]"
+
+DEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# TOFIX: tests go in an infinite loop error
+RESTRICT=test
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}