summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-21 19:17:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-21 22:17:37 +0200
commitde1a7d254adaf1ddb13b72d249ced0da6447332c (patch)
tree00aef0342481aa61884b84a1ae0e4f7ef7790f4d /dev-python/rsa
parentdev-python/pymongo: Bump to 4.2.0 (diff)
downloadgentoo-de1a7d254adaf1ddb13b72d249ced0da6447332c.tar.gz
gentoo-de1a7d254adaf1ddb13b72d249ced0da6447332c.tar.bz2
gentoo-de1a7d254adaf1ddb13b72d249ced0da6447332c.zip
dev-python/rsa: Bump to 4.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rsa')
-rw-r--r--dev-python/rsa/Manifest1
-rw-r--r--dev-python/rsa/rsa-4.9.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/rsa/Manifest b/dev-python/rsa/Manifest
index cec01cbc6a53..b59318b0d575 100644
--- a/dev-python/rsa/Manifest
+++ b/dev-python/rsa/Manifest
@@ -1 +1,2 @@
DIST python-rsa-version-4.8.gh.tar.gz 73634 BLAKE2B 55f25b6747f4f0bad12cbbb75c6e6fdbe6f913265866f11430644b46f9d3a2f615e6ed460d04cc732cfe29f0a4e47b14f2581f29d523b3018272ef976a6a04aa SHA512 d65e5d3c902508f4ea7424099471cd68568b052b9647a87ceb155ecc444ba6a8bd0ebef6fe1bf38720a19193cd494a8b64f744cca5812d1a3bec28f3fa3a9a3d
+DIST python-rsa-version-4.9.gh.tar.gz 59238 BLAKE2B 077679131fcd29a0f396ad9db45db9a6891be45afe96a328f66191d747f10d36a3248b0929d5c8270ff32a39d08a9c15d80973ba3af83f7368e792cf003f186a SHA512 0b49c1e5ffb6235ccb9e34c81ad717276c04956e21dd54c08b5cae7dd28ecc115235b2793c8bfc2fbb46a260e574d35cab23729567efeee108b79544793e60ad
diff --git a/dev-python/rsa/rsa-4.9.ebuild b/dev-python/rsa/rsa-4.9.ebuild
new file mode 100644
index 000000000000..a75385ddf3e9
--- /dev/null
+++ b/dev-python/rsa/rsa-4.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=python-rsa-version-${PV}
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="
+ https://stuvel.eu/rsa/
+ https://github.com/sybrenstuvel/python-rsa/
+ https://pypi.org/project/rsa/
+"
+SRC_URI="
+ https://github.com/sybrenstuvel/python-rsa/archive/version-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ rm tests/test_mypy.py || die
+ distutils-r1_src_prepare
+}