summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-05-13 20:09:13 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-05-13 23:45:18 +0100
commit5571a2c3b6314d2eea69068dce13adb398a25849 (patch)
treefbdb7d2ffdef6564c0f04f76607ae1e23103364f /dev-python/s3transfer/s3transfer-0.1.13.ebuild
parenteapi7-ver.eclass: Support EAPIs 0 to 6. (diff)
downloadgentoo-5571a2c3b6314d2eea69068dce13adb398a25849.tar.gz
gentoo-5571a2c3b6314d2eea69068dce13adb398a25849.tar.bz2
gentoo-5571a2c3b6314d2eea69068dce13adb398a25849.zip
dev-python/s3transfer: add new version 0.1.13
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-python/s3transfer/s3transfer-0.1.13.ebuild')
-rw-r--r--dev-python/s3transfer/s3transfer-0.1.13.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.1.13.ebuild b/dev-python/s3transfer/s3transfer-0.1.13.ebuild
new file mode 100644
index 000000000000..fe60b291ed8a
--- /dev/null
+++ b/dev-python/s3transfer/s3transfer-0.1.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="An Amazon S3 Transfer Manager"
+HOMEPAGE="https://github.com/boto/s3transfer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/botocore-1.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/futures-2.2.0[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep '<dev-python/futures-4.0.0[${PYTHON_USEDEP}]' 'python2_7')
+"
+# Pin mock to 1.3.0 if testing failures due to mock occur.
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${CDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "tests failed under ${EPYTHON}"
+}