summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-29 04:14:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-29 04:14:58 +0200
commitb2290a4c5a26519e336527c03bcfca0b0bcb972f (patch)
tree8464624906c43bfac82c59fe1ab7cc326d92e5f0 /dev-python/scikit-build-core
parentdev-python/fakeredis: Bump to 2.25.0 (diff)
downloadgentoo-b2290a4c5a26519e336527c03bcfca0b0bcb972f.tar.gz
gentoo-b2290a4c5a26519e336527c03bcfca0b0bcb972f.tar.bz2
gentoo-b2290a4c5a26519e336527c03bcfca0b0bcb972f.zip
dev-python/scikit-build-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.10.5.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index 9f5f70cb9b21..af0b6ed02e44 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,3 +1,2 @@
-DIST scikit_build_core-0.10.5.tar.gz 253285 BLAKE2B 6bbd5a92987fcbf9880df902784c9ee1a53d3f58b935b0c43ceb9bb8be0c32878845dd4c35fd03569fdc74d053866ff5e93b8eb96b058623fb357351a16919ec SHA512 283a50b4ff99e9c99fd92f0198231d0c8b68dcfc47ca5a782d7d604d9a313225f9f4e3dbc9490d9cd04f4d66cb79a4f793fb416763717474e83a3fea356b9bac
DIST scikit_build_core-0.10.6.tar.gz 254624 BLAKE2B da23ecf36e16f2d8f1b4daeb41c3cd7ca5af1cd0a4eff324765920a53410b9a6d5c7456247dd310b67ac0fc9a96547f1aa6f019e7d7527b603184a9199c863d2 SHA512 e3ee9aff752d2531c3bc44f8288a4619637e89d4a0edea3aef012153ba31af9a86929437e9d11b1d1a6d85a60a9a4da34cc347c203b80cca3caee05fb3e832da
DIST scikit_build_core-0.10.7.tar.gz 255019 BLAKE2B 8cacc08d0ef5e23fb72e93215cbfb68d72cd93c88b2b63149f44dbe307c6fd4ea623955decd67fef5925b135dab2e5d0c66ab683037d98ec8cea926e3655f090 SHA512 dcd9e3170f7fb0251ce2353ecd5080b64c16b914f2afe8380d318388f1d2fdbe9ca989ed2bffa44963b1ce629e7fa1545132d003f60d76b35e8c680418d883da
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.10.5.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.10.5.ebuild
deleted file mode 100644
index b81a230f1d4a..000000000000
--- a/dev-python/scikit-build-core/scikit-build-core-0.10.5.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Build backend for CMake based projects"
-HOMEPAGE="
- https://github.com/scikit-build/scikit-build-core/
- https://pypi.org/project/scikit-build-core/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 ~sparc x86"
-
-# we always want [pyproject] extra
-RDEPEND="
- app-alternatives/ninja
- dev-build/cmake
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/exceptiongroup[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
- dev-python/fastjsonschema[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local _EPYTEST_DESELECT=(
- # TODO / we don't package validate_pyproject anyway
- tests/test_schema.py::test_compare_schemas
- # setuptools now respects PEP 625
- tests/test_setuptools_pep517.py::test_pep517_sdist
- )
- local EPYTEST_IGNORE=(
- # needs unpackaged validate_pyproject
- tests/test_schema.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest-subprocess -m "not isolated and not network"
-}