summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-18 19:20:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-18 19:20:34 +0200
commit3a81262b96abc5bc59bb8f6cfc9f0f5876a7ed84 (patch)
treee26963506d7170b15e78fb1b6e61fd335e191289 /dev-python/scikit-build
parentdev-python/hcloud-python: Remove old (diff)
downloadgentoo-3a81262b96abc5bc59bb8f6cfc9f0f5876a7ed84.tar.gz
gentoo-3a81262b96abc5bc59bb8f6cfc9f0f5876a7ed84.tar.bz2
gentoo-3a81262b96abc5bc59bb8f6cfc9f0f5876a7ed84.zip
dev-python/scikit-build: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest3
-rw-r--r--dev-python/scikit-build/scikit-build-0.16.4.ebuild70
-rw-r--r--dev-python/scikit-build/scikit-build-0.16.7.ebuild70
-rw-r--r--dev-python/scikit-build/scikit-build-0.17.5.ebuild58
4 files changed, 0 insertions, 201 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index 7f517f98de26..5fba8e6d3153 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -1,4 +1 @@
-DIST scikit-build-0.16.4.tar.gz 271037 BLAKE2B 6cca8a3c4f4b37228b77ac098650a5eca4ad0f525ca7dcba178f4cffabb7e60e9a7bbba244e64c1a598ab5916f2f47788198eb2a19803d8d0cf7b9792f4e06e2 SHA512 90315ceac4c372e4d7248b4b56b6092362c2c43fbdc180d1a234e057209c508a05d2c6e0a3d0c2587c3adb8957e4c66d5c171a2a2bc3dbf9874a0de58d97d976
-DIST scikit-build-0.16.7.tar.gz 274287 BLAKE2B 8a5064c021d904312ccf89a396ab794b89b73ad1b6238767ca74eeb394f0f1514eedd3c746353ee3e9e7b825988b3c52c563e1f19d0acfbe69213c5a306f1dcc SHA512 5bba94214c249f891b2972301b0e37b5f10938151e37a04b845dfc9e11ae85edc7e3880984f9fbbd1c037257fc8baa3ba7b006b1f1b7abb941d1a54e049f3cbc
-DIST scikit_build-0.17.5.tar.gz 269848 BLAKE2B df1ec6ff3791efeea0ea7b672b7c5d2ad946c9c8d1e8b7035f4036315701ad1b7d61b0917e75ca8c9aff10fe8f25e53b8d1221fa6c3b554225ff8d8f5dec5fd4 SHA512 f0c9a861f9931db36df137d96a9a53d2bfa4a696efc2c1307ff50a00f7df828042d933ef1f670d14d0a339ccf5b94ce99fca7ffbab9169b6e70c47440f4eef06
DIST scikit_build-0.17.6.tar.gz 272208 BLAKE2B 9e3f908041eca89182f798c54a1a248934dc026816f7cd041a8debc97be27096942dda42a0ae63e87b9337304a478d6f520edcd5ea7a45aae6a195d1f769eed2 SHA512 92b97146f40d8222bd8415ef8439497d5075b72e5bafc40aba0a3e2911d269a118f2f7d41f468f7add8949f550b1fd7d5a9113d249e42dfac431108182ca9198
diff --git a/dev-python/scikit-build/scikit-build-0.16.4.ebuild b/dev-python/scikit-build/scikit-build-0.16.4.ebuild
deleted file mode 100644
index 748a4a515efc..000000000000
--- a/dev-python/scikit-build/scikit-build-0.16.4.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
-HOMEPAGE="
- https://github.com/scikit-build/scikit-build/
- https://pypi.org/project/scikit-build/
-"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-rtd-theme \
- dev-python/sphinx-issues
-distutils_enable_tests pytest
-
-src_prepare() {
- # not packaged
- sed -i -e '/cmakedomain/d' docs/conf.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # sandbox violations
- tests/test_hello_cpp.py::test_hello_develop
- tests/test_issue274_support_default_package_dir.py
- tests/test_issue274_support_one_package_without_package_dir.py
- tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py
- tests/test_pep518.py
- # This fails because of additional item setup.py in sources
- tests/test_include_exclude_data.py::test_hello_sdist
- tests/test_include_exclude_data.py::test_hello_sdist_with_base
- tests/test_issue401_sdist_with_symlinks.py::test_sdist_with_symlinks
- tests/test_manifest_in.py::test_manifest_in_sdist
- # Wants internet to install things with pip
- tests/test_numpy.py::test_pep518_findpython
- # TODO
- "tests/test_command_line.py::test_hide_listing[True-bdist_wheel]"
- )
- epytest
-}
diff --git a/dev-python/scikit-build/scikit-build-0.16.7.ebuild b/dev-python/scikit-build/scikit-build-0.16.7.ebuild
deleted file mode 100644
index 576cc23dc77b..000000000000
--- a/dev-python/scikit-build/scikit-build-0.16.7.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
-HOMEPAGE="
- https://github.com/scikit-build/scikit-build/
- https://pypi.org/project/scikit-build/
-"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/setuptools-42.0.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- >=dev-python/cython-0.25.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-1.10.4[${PYTHON_USEDEP}]
- >=dev-python/pytest-virtualenv-1.2.5[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-rtd-theme \
- dev-python/sphinx-issues
-distutils_enable_tests pytest
-
-src_prepare() {
- # not packaged
- sed -i -e '/cmakedomain/d' docs/conf.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # sandbox violations
- tests/test_hello_cpp.py::test_hello_develop
- tests/test_issue274_support_default_package_dir.py
- tests/test_issue274_support_one_package_without_package_dir.py
- tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py
- tests/test_pep518.py
- # This fails because of additional item setup.py in sources
- tests/test_include_exclude_data.py::test_hello_sdist
- tests/test_include_exclude_data.py::test_hello_sdist_with_base
- tests/test_issue401_sdist_with_symlinks.py::test_sdist_with_symlinks
- tests/test_manifest_in.py::test_manifest_in_sdist
- # Wants internet to install things with pip
- tests/test_numpy.py::test_pep518_findpython
- # TODO
- "tests/test_command_line.py::test_hide_listing[True-bdist_wheel]"
- )
- epytest
- rm -r "${BUILD_DIR}/install$(python_get_sitedir)"/{easy-install.pth,*.egg} || die
-}
diff --git a/dev-python/scikit-build/scikit-build-0.17.5.ebuild b/dev-python/scikit-build/scikit-build-0.17.5.ebuild
deleted file mode 100644
index c2e7d49eaf06..000000000000
--- a/dev-python/scikit-build/scikit-build-0.17.5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
-HOMEPAGE="
- https://github.com/scikit-build/scikit-build/
- https://pypi.org/project/scikit-build/
-"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/setuptools-42.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{9..10})
- >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- >=dev-python/build-0.7[${PYTHON_USEDEP}]
- >=dev-python/cython-0.25.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-1.10.4[${PYTHON_USEDEP}]
- >=dev-python/pytest-virtualenv-1.2.5[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-rtd-theme \
- dev-python/sphinx-issues
-distutils_enable_tests pytest
-
-src_prepare() {
- # not packaged
- sed -i -e '/cmakedomain/d' docs/conf.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- epytest -m "not isolated and not nosetuptoolsscm"
- rm -r "${BUILD_DIR}/install$(python_get_sitedir)"/{easy-install.pth,*.egg,*.egg-link} || die
-}