summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-13 07:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-13 07:12:57 +0200
commit7d8bbd90a83ff15f47d948bd705b5a6d41a7360a (patch)
tree7a98909abd682f4123e2d50b9277683d832c80d9 /dev-python/scikit-build
parentdev-python/tekore: Bump to 4.6.0 (diff)
downloadgentoo-7d8bbd90a83ff15f47d948bd705b5a6d41a7360a.tar.gz
gentoo-7d8bbd90a83ff15f47d948bd705b5a6d41a7360a.tar.bz2
gentoo-7d8bbd90a83ff15f47d948bd705b5a6d41a7360a.zip
dev-python/scikit-build: Bump to 0.17.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest1
-rw-r--r--dev-python/scikit-build/scikit-build-0.17.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index 457b79286c0a..dcb5529266b8 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -3,3 +3,4 @@ DIST scikit-build-0.16.5.tar.gz 271974 BLAKE2B e34d44fb27975720adc4ca57a0fabc9b0
DIST scikit-build-0.16.6.tar.gz 272201 BLAKE2B bb14b0db52d0c04b9630fa27ccbc58c7af72eb8640c4dc82e920acdbc815e2eb8f7662684b23aa42765966ae1ad4e046dead3d7090a263d79f69bfd955ab0f24 SHA512 f36a46845420b441ca158ea05bc20023238afdf81b2108554a52a4a2be0cb19ef6b2729997199d9a9d18841c8470df8f7e7a986a86e1172328f0963f3a015f3d
DIST scikit-build-0.16.7.tar.gz 274287 BLAKE2B 8a5064c021d904312ccf89a396ab794b89b73ad1b6238767ca74eeb394f0f1514eedd3c746353ee3e9e7b825988b3c52c563e1f19d0acfbe69213c5a306f1dcc SHA512 5bba94214c249f891b2972301b0e37b5f10938151e37a04b845dfc9e11ae85edc7e3880984f9fbbd1c037257fc8baa3ba7b006b1f1b7abb941d1a54e049f3cbc
DIST scikit_build-0.17.0.tar.gz 266282 BLAKE2B ca8d9fbb422363850b4ad12d3b8e2ad6e1664b8b7354c64e6fc1ad4ab1965a3be92c24699041b67dc91c2be02f7d17be3eefd9a909ea0380149eb5b58e01ea49 SHA512 0ad536ac624eecc0710b5e65ec976cc9f8eb15f0017edf79016724ae8321909c134cf9b6842f58d80b3e62edad95652987339e26e3c576b909adccd3a2f492d1
+DIST scikit_build-0.17.1.tar.gz 267911 BLAKE2B 365e7e4bcc902a00464b157feaee4efcddff3fca8c8026b252b25b44de5ed5a646c21d29df55133d6945868f346f638c5adcf9da530b1ff6bcb5689d0f33bf90 SHA512 617a68d92787c576f1c3fc9c24c8cc90e1fe976a853f3ae81442e1a99a20e1f4049d7ffac967c2248bf172f07a3e2092fc28b8d558b35da628a58cd3d9d16ae3
diff --git a/dev-python/scikit-build/scikit-build-0.17.1.ebuild b/dev-python/scikit-build/scikit-build-0.17.1.ebuild
new file mode 100644
index 000000000000..a0aa5f26f381
--- /dev/null
+++ b/dev-python/scikit-build/scikit-build-0.17.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build/
+ https://pypi.org/project/scikit-build/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-42.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/build-0.7[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.25.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.10.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-virtualenv-1.2.5[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+src_prepare() {
+ # not packaged
+ sed -i -e '/cmakedomain/d' docs/conf.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -m "not isolated and not nosetuptoolsscm"
+ rm -r "${BUILD_DIR}/install$(python_get_sitedir)"/{easy-install.pth,*.egg,*.egg-link} || die
+}