summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-15 09:23:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-15 09:24:21 +0200
commit998128b2c64ee399d18d7cdcf43bb1483877cbaf (patch)
treed5753c1f9b8c720768f712303ca187f3a24dc3f7 /dev-python/scikit-build
parentdev-python/sip: Remove old (diff)
downloadgentoo-998128b2c64ee399d18d7cdcf43bb1483877cbaf.tar.gz
gentoo-998128b2c64ee399d18d7cdcf43bb1483877cbaf.tar.bz2
gentoo-998128b2c64ee399d18d7cdcf43bb1483877cbaf.zip
dev-python/scikit-build: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest1
-rw-r--r--dev-python/scikit-build/files/scikit-build-0.12.0-tests-no-coverage.patch11
-rw-r--r--dev-python/scikit-build/scikit-build-0.14.1.ebuild68
3 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index 85bdaf8cb8d2..68d0041c10b9 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -1,2 +1 @@
-DIST scikit-build-0.14.1.tar.gz 266776 BLAKE2B cb674412ef000fa961b85b32bf7759430cc5ff1b175e29017219ae3b941bfefee5760742cf17549fe7868fa0fc80f72e027aa683cd07bec53c1578e27b1ea0a7 SHA512 c9c3caaab969e83739cb3be718fc7190ef25372fbbf689ea84f9b9725bfc8329640c26038d875ecf3ccdbab0637ef77d6a30c05dcdaaecf441f631c8601d3b63
DIST scikit-build-0.15.0.tar.gz 268691 BLAKE2B f4cb51ee2367bd4ba6f6c1cada15e1e6be731998a914b28edcf703c5a92c409b78b17dddf04a29b24d40f249ffa06eb9d05d36dc30c0e62ee001519c3ca03f58 SHA512 4d9b1d06d48708ff4f2f5fa8c8f264c7ca85946d5842a1254930d9449d6b6386c17392473c3c85147f6573f7256c94c927962cb56fa23a90a5b442de8de8d727
diff --git a/dev-python/scikit-build/files/scikit-build-0.12.0-tests-no-coverage.patch b/dev-python/scikit-build/files/scikit-build-0.12.0-tests-no-coverage.patch
deleted file mode 100644
index 993258961f35..000000000000
--- a/dev-python/scikit-build/files/scikit-build-0.12.0-tests-no-coverage.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -10,7 +10,7 @@
-
- [tool:pytest]
- testpaths = tests
--addopts = -v --cov --cov-report xml -ra --strict-markers --showlocals --color=yes
-+addopts = -v -ra --strict-markers --showlocals --color=yes
- markers =
- fortran: fortran testing
-
diff --git a/dev-python/scikit-build/scikit-build-0.14.1.ebuild b/dev-python/scikit-build/scikit-build-0.14.1.ebuild
deleted file mode 100644
index 51a4443468d2..000000000000
--- a/dev-python/scikit-build/scikit-build-0.14.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
-HOMEPAGE="
- https://github.com/scikit-build/scikit-build/
- https://pypi.org/project/scikit-build/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86"
-
-RDEPEND="
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- test? (
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/sphinx-issues
-distutils_enable_tests pytest
-
-src_prepare() {
- # not packaged
- sed -i -e '/cmakedomain/d' docs/conf.py || die
- # no pytest-cov
- sed -i -e '/addopts =/d' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local deselect=(
- # sandbox violations
- tests/test_hello_cpp.py::test_hello_develop
- tests/test_issue274_support_default_package_dir.py
- tests/test_issue274_support_one_package_without_package_dir.py
- tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py
- tests/test_pep518.py
- # This fails because of additional item setup.py in sources
- tests/test_include_exclude_data.py::test_hello_sdist
- tests/test_include_exclude_data.py::test_hello_sdist_with_base
- tests/test_issue401_sdist_with_symlinks.py::test_sdist_with_symlinks
- tests/test_manifest_in.py::test_manifest_in_sdist
- )
- epytest ${deselect[@]/#/--deselect }
-}