summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-24 07:14:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-24 07:32:38 +0200
commit70e28b8a95bc8cf3e5f33c9e42db04a05c8976d2 (patch)
tree135ed27b14507fcf746201749594819bdb4606c8 /dev-python/semantic-version
parentdev-python/orjson: Bump to 3.8.13 (diff)
downloadgentoo-70e28b8a95bc8cf3e5f33c9e42db04a05c8976d2.tar.gz
gentoo-70e28b8a95bc8cf3e5f33c9e42db04a05c8976d2.tar.bz2
gentoo-70e28b8a95bc8cf3e5f33c9e42db04a05c8976d2.zip
Rename dev-python/{semantic_version → semantic-version}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/semantic-version')
-rw-r--r--dev-python/semantic-version/Manifest1
-rw-r--r--dev-python/semantic-version/metadata.xml21
-rw-r--r--dev-python/semantic-version/semantic-version-2.10.0.ebuild27
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/semantic-version/Manifest b/dev-python/semantic-version/Manifest
new file mode 100644
index 000000000000..8aabf18478cc
--- /dev/null
+++ b/dev-python/semantic-version/Manifest
@@ -0,0 +1 @@
+DIST semantic_version-2.10.0.tar.gz 52289 BLAKE2B bb26ac31e71974376b40893cf000fe0d85e1e3e4c7c93372f2bfca841a5d760a99ca49d67f80c6e8707e60e313162b786300109f6f8cd1cfaa0001c343bc4702 SHA512 869a3901d4fc12acb285c94175011ed03dc00b35ab687c67dda458cffab5666cea21bc1b4bf75ef4edeb83b8080452a1c1470248eee54bbd269614a8cab132dc
diff --git a/dev-python/semantic-version/metadata.xml b/dev-python/semantic-version/metadata.xml
new file mode 100644
index 000000000000..920bd3fa3a30
--- /dev/null
+++ b/dev-python/semantic-version/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This small python library provides a few tools to handle SemVer in Python. It follows strictly the 2.0.0 version of the SemVer scheme.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">semantic-version</remote-id>
+ <remote-id type="github">rbarrois/python-semanticversion</remote-id>
+ <bugs-to>https://github.com/rbarrois/python-semanticversion/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/semantic-version/semantic-version-2.10.0.ebuild b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
new file mode 100644
index 000000000000..2b6c882264cf
--- /dev/null
+++ b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python library providing a few tools handling SemVer in Python"
+HOMEPAGE="
+ https://github.com/rbarrois/python-semanticversion/
+ https://pypi.org/project/semantic-version/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:django
+}