summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-08 06:57:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-08 07:00:41 +0200
commitd78354a61b913949624ee07fce6afbc2fa51d55f (patch)
tree6f136b09e3add151026731c94efa2ab583fc0852 /dev-python/sentry-sdk
parentapp-text/qpdf: Bump to 11.9.1 (diff)
downloadgentoo-d78354a61b913949624ee07fce6afbc2fa51d55f.tar.gz
gentoo-d78354a61b913949624ee07fce6afbc2fa51d55f.tar.bz2
gentoo-d78354a61b913949624ee07fce6afbc2fa51d55f.zip
dev-python/sentry-sdk: Bump to 2.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-2.5.1.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 2ea504de91ce..5976196d8d56 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -4,3 +4,4 @@ DIST sentry-python-2.2.1.gh.tar.gz 506079 BLAKE2B 396664193906b1712950d6776f7e6e
DIST sentry-python-2.3.1.gh.tar.gz 511775 BLAKE2B 5cc0cf6a225b8619df76492abbce76d01631148dc73aeea47d13c71435e973af7cc7904ef50e7edcde5821bce28b213b5e3ca3208887688e2d4cec1d03c7d54e SHA512 12ccd25142fd42262735babe986f9972571b4a3c48607c47c8b6887e722f53a964e259e82be56cf4c4ba6d14efe8335ebb32ed98a40a763a63a5f7b52ef6ce9e
DIST sentry-python-2.4.0.gh.tar.gz 512867 BLAKE2B 6473ce92ee5d9886bdca7dd13770f6639de64e7fcf4bc6cd0aa966aeab483abc6a884a96158c9627402bbaefd6678fc987518380e2b395fecd386e12431a89a5 SHA512 a1b539ffe6b538f0f3fabd3c6df2997b08ca2ba9e9bcef19f01dbde384de5b31c9795a80c2862172c0ccd918e878c90d42e04b15ed44222340ffc56d1f7f1c7e
DIST sentry-python-2.5.0.gh.tar.gz 514977 BLAKE2B 010c15ec1bf51d6a3a3f01f39715d81e63e640ff34c83f1b8cbb5c6049b14e3473ddd26739807e123a661f03ee2ae45c86e4a8ec762216c30b8d7421d29617c0 SHA512 4b138b55cdc8222d858335d9fc16f0b0134d6bdcc99bb7bc6548df4551939074a5265ad37f4558d7d667d0fc701517916a339781d83084e4cb262beb9af21f3c
+DIST sentry-python-2.5.1.gh.tar.gz 515056 BLAKE2B fab3e6e4faa1f07879fc679d43d86fc9590ba3049f5117efe69827a5678b7292c30c9e2d04992a2d75abe54498c3e6fe0366cea210e81b92ccf302c7abcf7e3c SHA512 6467e3836af9f44be93c9a9d0b2e4cf341b7ea4b70937a9624f5d53b746f9a5d2ee5507056c3f58662e0382d88bd3a9851b2ebdf2438bd39e4d5b15096d84a3b
diff --git a/dev-python/sentry-sdk/sentry-sdk-2.5.1.ebuild b/dev-python/sentry-sdk/sentry-sdk-2.5.1.ebuild
new file mode 100644
index 000000000000..e76b77593e45
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-2.5.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
+)
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/django/test_basic.py
+ tests/integrations/socket/test_socket.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: most of them hang
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+ # requires AWS access
+ tests/integrations/aws_lambda
+ # requires quart_auth
+ tests/integrations/quart
+ # TODO: require opentelemetry (with py3.10)
+ tests/integrations/opentelemetry
+ # broken (incompatible rq version?)
+ tests/integrations/rq
+ )
+
+ local EPYTEST_DESELECT=(
+ # hangs
+ tests/integrations/threading/test_threading.py::test_propagates_threadpool_hub
+ # broken teardown?
+ tests/test_client.py::test_uwsgi_warnings
+ # too many dependencies installed, sigh
+ tests/test_new_scopes_compat_event.py
+ # Internet
+ tests/integrations/stdlib/test_httplib.py::test_outgoing_trace_headers
+ tests/integrations/stdlib/test_httplib.py::test_outgoing_trace_headers_head_sdk
+ # TODO
+ tests/integrations/aiohttp/test_aiohttp.py::test_basic
+ tests/integrations/django
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_orm_queries
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_query_source
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_transactions
+ tests/integrations/stdlib/test_subprocess.py::test_subprocess_basic
+ tests/integrations/threading/test_threading.py
+ tests/integrations/wsgi/test_wsgi.py
+ tests/test_basics.py::test_auto_enabling_integrations_catches_import_error
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_utils.py::test_default_release
+ tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sample_rate_enabled
+ tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sampler_enabled
+ tests/utils/test_contextvars.py::test_leaks
+ # pointless, fragile to packages being installed in parallel
+ tests/test_utils.py::test_installed_modules
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p aiohttp -p pytest_forked
+}