summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-16 16:08:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-16 16:09:21 +0100
commitbb817991bf7470ad52ac7033fd3e1be18a543754 (patch)
treee8c2ea92652a19ea240c00029ce0efb0502b2e81 /dev-python/setuptools-gettext
parentdev-python/expandvars: Bump to 0.12.0 (diff)
downloadgentoo-bb817991bf7470ad52ac7033fd3e1be18a543754.tar.gz
gentoo-bb817991bf7470ad52ac7033fd3e1be18a543754.tar.bz2
gentoo-bb817991bf7470ad52ac7033fd3e1be18a543754.zip
dev-python/setuptools-gettext: Bump to 0.1.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools-gettext')
-rw-r--r--dev-python/setuptools-gettext/Manifest1
-rw-r--r--dev-python/setuptools-gettext/setuptools-gettext-0.1.8.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/setuptools-gettext/Manifest b/dev-python/setuptools-gettext/Manifest
index 5ce91d8aa038..a9a6292e4423 100644
--- a/dev-python/setuptools-gettext/Manifest
+++ b/dev-python/setuptools-gettext/Manifest
@@ -1 +1,2 @@
DIST setuptools-gettext-0.1.3.tar.gz 10654 BLAKE2B 801adc5f09facff215009ee61cef6996866efced51424a9dbcc6ace76e132b75d3cc8293eecbe0958372966e9faa64c73d7f743d2bb6187b448d9becf6106c8c SHA512 786e9f9280013759e96fe16551ba2dafef033d7d1faadc9bf9306c6442ba242d638778b45c8c228a2ff04038903958bc1db435c4982b665d73ba15fcc4bd9eee
+DIST setuptools-gettext-0.1.8.tar.gz 15548 BLAKE2B 4e1dcd219fca132e859a44e7ab86f0c81ac2dfccf5d2aca89ac05a2a3a50fec715a5e23e44173e741330d874d1f721ac8ec9d73d79b586ab605fb281aba8aafe SHA512 55b6512061565f210596972db3033d3d4f555428d23d1cac93feb3ea540461e908585d13157bcf97335f07b5a86e0b823b15457fe2f107ffc49e2e1b0c7a0c1e
diff --git a/dev-python/setuptools-gettext/setuptools-gettext-0.1.8.ebuild b/dev-python/setuptools-gettext/setuptools-gettext-0.1.8.ebuild
new file mode 100644
index 000000000000..71b027b2d6e3
--- /dev/null
+++ b/dev-python/setuptools-gettext/setuptools-gettext-0.1.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Setuptools plugin for building mo files"
+HOMEPAGE="
+ https://pypi.org/project/setuptools-gettext/
+ https://github.com/breezy-team/setuptools-gettext
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+python_test() {
+ cd example || die
+ distutils_pep517_install "${T}/${EPYTHON}"
+ if [[ ! -f ${T}/${EPYTHON}/usr/share/locale/nl/LC_MESSAGES/hallowereld.mo ]]
+ then
+ die ".mo file not installed"
+ fi
+}