summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/setuptools_scm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/setuptools_scm')
-rw-r--r--dev-python/setuptools_scm/Manifest2
-rw-r--r--dev-python/setuptools_scm/metadata.xml9
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-1.5.4.ebuild24
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-1.5.5.ebuild25
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm/Manifest b/dev-python/setuptools_scm/Manifest
new file mode 100644
index 000000000000..c40609edd40a
--- /dev/null
+++ b/dev-python/setuptools_scm/Manifest
@@ -0,0 +1,2 @@
+DIST setuptools_scm-1.5.4.tar.gz 15647 SHA256 756fb77b82c5e22818683b838c978537f4894f468ea074f0e8a99d8aaf689022 SHA512 c1e7c6b510761a3dcf3ebfed4988db924f9203c9f919891c94623f07935b101690ff2671ff3e153906a89f05d4002154e671196ba711597d4e3e7c8d0602289e WHIRLPOOL a02209c4c3c8ef6de63463ec163c018906de88abc5e1786b9506c4fc71dfdbe4b576cce94d19d653f1eb6f21f86292a645823b009107a07801056fb1f90a79b0
+DIST setuptools_scm-1.5.5.tar.gz 17442 SHA256 63f56843b9cc18743c843e43d54fd78ab091cb82d01f5acb64655743e8002134 SHA512 39516db6164dc0d6179922fd79b012950c0684c8f6d4dbf71c2fcae661d1a54ef745c48c8d521ed3906c4f74d91b79fe4a94b5e27ab6a84701964494057c2494 WHIRLPOOL 929e5c38aaef9c247a451382842bf16faf44528858981af7c29133d5b3f4693414b85d076ade33c033dfbadb5803bf1b95fa5d8fa942725af2c3b01534d72a72
diff --git a/dev-python/setuptools_scm/metadata.xml b/dev-python/setuptools_scm/metadata.xml
new file mode 100644
index 000000000000..3799991af722
--- /dev/null
+++ b/dev-python/setuptools_scm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">setuptools_scm</remote-id>
+ <remote-id type="bitbucket">pypa/setuptools_scm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/setuptools_scm/setuptools_scm-1.5.4.ebuild b/dev-python/setuptools_scm/setuptools_scm-1.5.4.ebuild
new file mode 100644
index 000000000000..46e3f9b7fbe1
--- /dev/null
+++ b/dev-python/setuptools_scm/setuptools_scm-1.5.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="http://bitbucket.org/pypa/setuptools_scm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/setuptools_scm/setuptools_scm-1.5.5.ebuild b/dev-python/setuptools_scm/setuptools_scm-1.5.5.ebuild
new file mode 100644
index 000000000000..0d9a43c28f99
--- /dev/null
+++ b/dev-python/setuptools_scm/setuptools_scm-1.5.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die "tests failed under ${EPYTHON}"
+}