summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-20 16:57:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-20 16:57:30 +0100
commit7cb14e4c2124177eb798944b29163b475182d861 (patch)
tree0d22c6d52ab1d28d4986ed603f0a6b4e98d1bc2f /dev-python/shapely
parentdev-python/freezegun: Stabilize 1.3.1 ALLARCHES, #920411 (diff)
downloadgentoo-7cb14e4c2124177eb798944b29163b475182d861.tar.gz
gentoo-7cb14e4c2124177eb798944b29163b475182d861.tar.bz2
gentoo-7cb14e4c2124177eb798944b29163b475182d861.zip
dev-python/shapely: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/shapely-2.0.2.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/shapely/shapely-2.0.2.ebuild b/dev-python/shapely/shapely-2.0.2.ebuild
deleted file mode 100644
index acfc3a8a7763..000000000000
--- a/dev-python/shapely/shapely-2.0.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=${P/_p/.post}
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="
- https://pypi.org/project/shapely/
- https://github.com/shapely/shapely/
-"
-SRC_URI="
- https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~x86"
-
-DEPEND="
- >=sci-libs/geos-3.9
-"
-RDEPEND="
- ${DEPEND}
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${DEPEND}
- >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- rm -rf shapely || die
- epytest --pyargs shapely
-}