summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-03-15 20:20:12 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-03-15 20:33:52 +0200
commitb446e4aeba19327d036fa02a118bb7d422fcbecc (patch)
tree8153f9ad7f9c40d58d05637778dbd2e13f600713 /dev-python/signature_dispatch
parentapp-editors/vscode: add 1.76.2 (diff)
downloadgentoo-b446e4aeba19327d036fa02a118bb7d422fcbecc.tar.gz
gentoo-b446e4aeba19327d036fa02a118bb7d422fcbecc.tar.bz2
gentoo-b446e4aeba19327d036fa02a118bb7d422fcbecc.zip
dev-python/signature_dispatch: add 1.0.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/signature_dispatch')
-rw-r--r--dev-python/signature_dispatch/Manifest1
-rw-r--r--dev-python/signature_dispatch/signature_dispatch-1.0.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/signature_dispatch/Manifest b/dev-python/signature_dispatch/Manifest
index 82b92a7f258f..44e11515b681 100644
--- a/dev-python/signature_dispatch/Manifest
+++ b/dev-python/signature_dispatch/Manifest
@@ -1 +1,2 @@
DIST signature_dispatch-1.0.0.tar.gz 15102 BLAKE2B d0fe384551136d23f815129849ec70c0d1bd8616dab571122b7407578f3cc0d614fc5c44f3de5d9541bed9e9e3a0887517fff1183fd6c782bde603d774fe09f1 SHA512 c13ac92f50a8bd7a9fcd0b231f74a14539fd9c0303fdb29860a93116512a20113708c3207c4b2d8f61a48a9632e8cd21f7ea3fcb49ae3a4b1c79eb6a71df4eab
+DIST signature_dispatch-1.0.1.tar.gz 15348 BLAKE2B 35356caae5f6f7ba28494c02142addb581a36520b8becd2e0e132f1e4a37002870c981475688b758a4733341d67cc4cb30b2a7b69b3d106570766eeed36104fc SHA512 656fb47c50d865d1afec53f389154e783792bcedd7443442a142d19bcbd352fe0eff41ae9ef74378bafc164bb386a8e9a6f57d762f34ad23557a44a5d0d0f5de
diff --git a/dev-python/signature_dispatch/signature_dispatch-1.0.1.ebuild b/dev-python/signature_dispatch/signature_dispatch-1.0.1.ebuild
new file mode 100644
index 000000000000..19d13a97f45b
--- /dev/null
+++ b/dev-python/signature_dispatch/signature_dispatch-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Execute the first function that matches the given arguments"
+HOMEPAGE="
+ https://github.com/kalekundert/signature_dispatch/
+ https://pypi.org/project/signature-dispatch/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+RDEPEND="
+ >=dev-python/typeguard-3.0.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}