summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-28 05:15:05 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-28 05:15:05 +0100
commita0d2ed9b291f4fffe91b9c5fe766d5c8b4997969 (patch)
treee495b94ae382dab905fd032b7de62ac3ac8472b3 /dev-python/simsimd
parentdev-python/simsimd: Remove old (diff)
downloadgentoo-a0d2ed9b291f4fffe91b9c5fe766d5c8b4997969.tar.gz
gentoo-a0d2ed9b291f4fffe91b9c5fe766d5c8b4997969.tar.bz2
gentoo-a0d2ed9b291f4fffe91b9c5fe766d5c8b4997969.zip
dev-python/simsimd: Bump to 5.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/simsimd')
-rw-r--r--dev-python/simsimd/Manifest1
-rw-r--r--dev-python/simsimd/simsimd-5.9.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/simsimd/Manifest b/dev-python/simsimd/Manifest
index f4a4a7fca52c..22cadbe22887 100644
--- a/dev-python/simsimd/Manifest
+++ b/dev-python/simsimd/Manifest
@@ -1 +1,2 @@
DIST SimSIMD-5.8.0.gh.tar.gz 183559 BLAKE2B 2df0eac6eff58bc6c460b37cb7c523eae5d7e77d516bc7182ef3b39d033a1028d40536aaf99ad8ec8c28b4908ff873079ff0ca3d74acd1f763b0faaa5d4e225e SHA512 4e68050379dfe42e6c36a88a0defad0d941c873bda66cb4c65bd8367b07bca99a5c5d6eec7c8e39b15ad1b8e5bcc9dc7f43457d8552e9d72faefb88b03ad6f9b
+DIST SimSIMD-5.9.2.gh.tar.gz 201732 BLAKE2B 2ca654f964fba71e54b8383390021fe87a731a85cac2509319944a3d0c0f60a09a7c1cf2fdb16a78ca20f3b7618e40960f2eac6c65fae6a06e583504df35890a SHA512 cf32776e05b91784d9a3a7d86a73a91549a22ce4612124f88412bb12bd356c654ce4e70c6a436f731d832a65cba8827d1100ff26f2b88fcaa234057f17d19aeb
diff --git a/dev-python/simsimd/simsimd-5.9.2.ebuild b/dev-python/simsimd/simsimd-5.9.2.ebuild
new file mode 100644
index 000000000000..3b7152ad7a71
--- /dev/null
+++ b/dev-python/simsimd/simsimd-5.9.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P=SimSIMD-${PV}
+DESCRIPTION="Fastest SIMD-Accelerated Vector Similarity Functions for x86 and Arm"
+HOMEPAGE="
+ https://github.com/ashvardanian/SimSIMD/
+ https://pypi.org/project/simsimd/
+"
+# no sdist, as of 4.3.1
+# https://github.com/ashvardanian/SimSIMD/issues/113
+SRC_URI="
+ https://github.com/ashvardanian/SimSIMD/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-repeat[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/-O3/d' setup.py || die
+ if ! use openmp; then
+ sed -i -e '/-fopenmp/d' setup.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p repeat scripts/test.py
+}