summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-01-26 23:17:04 -0500
committerMike Gilbert <floppym@gentoo.org>2016-01-26 23:17:15 -0500
commit0b734d0a83e1ca2490e44e7ccd5a363ba1410b9f (patch)
tree3bf8458b3f1516043efc69f4c26b382e38284028 /dev-python/six
parentdev-python/six: Force usage of distutils over setuptools (diff)
downloadgentoo-0b734d0a83e1ca2490e44e7ccd5a363ba1410b9f.tar.gz
gentoo-0b734d0a83e1ca2490e44e7ccd5a363ba1410b9f.tar.bz2
gentoo-0b734d0a83e1ca2490e44e7ccd5a363ba1410b9f.zip
dev-python/six: Drop the live ebuild
Package-Manager: portage-2.2.27_p49
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-9999.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/six/six-9999.ebuild b/dev-python/six/six-9999.ebuild
deleted file mode 100644
index 1807e5e4f34e..000000000000
--- a/dev-python/six/six-9999.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
-
-inherit distutils-r1 mercurial
-
-DESCRIPTION="Python 2 and 3 compatibility library"
-HOMEPAGE="https://bitbucket.org/gutworth/six https://pypi.python.org/pypi/six"
-SRC_URI=""
-EHG_REPO_URI="https://bitbucket.org/gutworth/six"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
- test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C documentation html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( documentation/_build/html/ )
- distutils-r1_python_install_all
-}